Bug 638924 - disk write error when boot guest from image on nfs
disk write error when boot guest from image on nfs
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.6
All Linux
low Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
: 638545 (view as bug list)
Depends On:
Blocks: Rhel5KvmTier2 600375
  Show dependency treegraph
 
Reported: 2010-09-30 07:52 EDT by slei
Modified: 2010-12-07 09:48 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-07 09:48:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description slei 2010-09-30 07:52:54 EDT
Description of problem:
VM is stopped due to disk write error when boot guest from nfs with qcow2 image format  

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. mount nfs
2. boot guest from nfs with werror=stop
/usr/libexec/qemu-kvm  -M rhel5.5.0 -m 2048 -smp 2 -name win7x86-Hel5-Del5 -uuid b51e36f4-ea66-42fa-bd9b-f92f4483bc13 -no-kvm-pit-reinjection -monitor stdio -localtime -boot c -drive file=./win08R2-Hel5-Del5.img,if=virtio,index=0,boot=on,werror=stop -net nic,macaddr=54:52:00:32:a5:12,vlan=0,model=virtio -net tap,script=/usr/local/staf/test/RHEV/kvm-new/autotest/client/tests/kvm/scripts/qemu-ifup-switch,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -usbdevice tablet -vnc :1 -k en-us
3. (qemu) info status 
VM status: paused
(qemu) info stop-reason 
VM is stopped due to disk write error: ide0-hd0: Cannot allocate memory

  
Actual results:


Expected results:


Additional info:
1. guest can boot successfully in local machine
2. guest can boot successfully on nfs with raw format.
3.  free -m
            total       used       free     shared    buffers     cached
 Mem:          7854        137       7717          0          3         39
 -/+ buffers/cache:         93       7760
 Swap:         9855          0
Comment 5 Jiri Denemark 2010-10-21 06:27:14 EDT
*** Bug 638545 has been marked as a duplicate of this bug. ***
Comment 7 Mike Cao 2010-11-08 01:58:32 EST
Tried on 2.6.18-230, can not hit this issue ,seems this issue has been fixed.
Comment 9 RHEL Product and Program Management 2010-12-07 05:27:21 EST
This request was evaluated by Red Hat Product Management for inclusion in Red Hat Enterprise Linux 5.6 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.
Comment 10 Ric Wheeler 2010-12-07 09:48:53 EST
It seems from comment 7 that this bug is fixed. Please reopen if not true.

Note You need to log in before you can comment on or make changes to this bug.