Bug 638934
| Summary: | Release Note: Installation on RHEL 5.4 fails to start httpd, due to old selinux-policy-tarteged package which does not get upgraded | ||
|---|---|---|---|
| Product: | Red Hat Satellite 5 | Reporter: | Jan Pazdziora (Red Hat) <jpazdziora> |
| Component: | Docs Release Notes | Assignee: | John Ha <jha> |
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Petr Sklenar <psklenar> |
| Severity: | high | Docs Contact: | |
| Priority: | medium | ||
| Version: | 530 | CC: | adstrong, cperry, jhutar, psklenar |
| Target Milestone: | --- | ||
| Target Release: | --- | ||
| Hardware: | All | ||
| OS: | Linux | ||
| Whiteboard: | Fixed in the 5.4.0 Release - GA'd 2010-10-27 | ||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2010-10-28 14:56:24 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | |||
| Bug Blocks: | 608749 | ||
Suggested text for Known Issues section: Please ensure that if installing Satellite 5.4 with SELinux in enforcing mode to update to newest selinux-policy-targeted due to known incompatibilities with older (Pre-RHEL 5.5) version of the selinux-policy-targeted package. Cliff release notes: If you are installing RHN Satellite 5.4 with SELinux in enforcing mode, ensure that you have updated to newest selinux-policy-targeted package due to known incompatibilities with older (prior to Red Hat Enterprise Linux 5.5) versions of the selinux-policy-targeted package. its part of the http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.4/html-single/Release_Notes/index.html -- verified The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332 RHEA-2010:0803 - RHN Tools enhancement update https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333 RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334 RHEA-2010:0800 - RHN Satellite Server 5.4.0 https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335 Docs are available: http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html Regards, Clifford |
Description of problem: When Satellite 5.4 is installed on RHEL 5.4 (as opposed to RHEL 5.5), the Apache server will not start after installation and the Satellite will not be usable. It'd caused by the AVC denial avc: denied { execute } for pid=27570 comm="httpd" name="satidmap.pl" dev=dm-0 ino=6422541 scontext=root:system_r:httpd_t:s0 tcontext=system_u:object_r:etc_t:s0 tclass=file which in turn is caused by Spacewalk SELinux policy modules not being loaded upon installation, as seen in /var/log/rhn/rhn-installation.log. That in turn is caused by the fact that we Require selinux-policy-base >= 2.4.6-267 but that selinux-policy-base Provides is not versioned, the the selinux-policy-targeted (which provides it) does not get upgraded. We would like a release note that the OS on which Satellite 5.4 is being installed should have its packages up-to-date. Version-Release number of selected component (if applicable): Satellite-5.4.0-RHEL5-re20100924.0 How reproducible: Deterministic. Steps to Reproduce: 1. Install on RHEL 5.4. Actual results: Apache does not start. Expected results: Release notes say you should have installed on RHEL 5.5. Additional info: