Bug 63894 - Fonts inaccessible after an installation
Fonts inaccessible after an installation
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-20 16:33 EDT by Michal Jaegermann
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-20 16:33:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2002-04-20 16:33:02 EDT
Description of Problem:

Say that we are installing fonts:

# rpm -Uvh  /mnt/cdrom/RedHat/RPMS/XFree86-base-fonts-4.2.0-6.52.i386.rpm
Preparing...                ########################################### [100%]
   1:XFree86-base-fonts     ########################################### [100%]

and now

# rpm -V XFree86-base-fonts-4.2.0-6.52
missing    /usr/X11R6/lib/X11/fonts/100dpi/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/100dpi/fonts.alias
.M...... g /usr/X11R6/lib/X11/fonts/100dpi/fonts.dir
missing    /usr/X11R6/lib/X11/fonts/75dpi/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/75dpi/fonts.alias
.M...... g /usr/X11R6/lib/X11/fonts/75dpi/fonts.dir
.M...... g /usr/X11R6/lib/X11/fonts/CID/fonts.dir
missing    /usr/X11R6/lib/X11/fonts/CID/fonts.scale
missing    /usr/X11R6/lib/X11/fonts/Speedo/encodings.dir
.M...... c /usr/X11R6/lib/X11/fonts/Speedo/fonts.dir
missing    /usr/X11R6/lib/X11/fonts/Speedo/fonts.scale
missing    /usr/X11R6/lib/X11/fonts/Type1/encodings.dir
.M...... c /usr/X11R6/lib/X11/fonts/Type1/fonts.dir
missing    /usr/X11R6/lib/X11/fonts/Type1/fonts.scale
missing    /usr/X11R6/lib/X11/fonts/local/fonts.dir
missing    /usr/X11R6/lib/X11/fonts/misc/encodings.dir
.M...... c /usr/X11R6/lib/X11/fonts/misc/fonts.dir

Surely enough various fonts are not accessible.  Actually various
fonts.dir are effectively empty.

With XFree86-base-fonts-4.2.0-6.666 from Mike's test sets 
this is better but still not really ok.  'rpm -V ...' gives:

missing    /usr/X11R6/lib/X11/fonts/100dpi/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/75dpi/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/CID/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/Speedo/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/Type1/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/local/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/local/fonts.dir
missing    /usr/X11R6/lib/X11/fonts/misc/encodings.dir

What is more for 4.2.0-6.52 'rpm -qvl ...' lists, among many
other things:

 3154 Mar 31 22:38 /usr/X11R6/lib/X11/fonts/100dpi/fonts.alias
84734 Mar 31 22:38 /usr/X11R6/lib/X11/fonts/100dpi/fonts.dir
 3066 Mar 31 22:38 /usr/X11R6/lib/X11/fonts/75dpi/fonts.alias
82434 Mar 31 22:38 /usr/X11R6/lib/X11/fonts/75dpi/fonts.dir
    2 Mar 31 22:38 /usr/X11R6/lib/X11/fonts/CID/fonts.dir
    2 Mar 31 22:38 /usr/X11R6/lib/X11/fonts/CID/fonts.scale
 1689 Mar 31 22:38 /usr/X11R6/lib/X11/fonts/Speedo/fonts.dir
 1689 Mar 31 22:38 /usr/X11R6/lib/X11/fonts/Speedo/fonts.scale
 5958 Mar 31 22:38 /usr/X11R6/lib/X11/fonts/Type1/fonts.dir
 5958 Mar 31 22:38 /usr/X11R6/lib/X11/fonts/Type1/fonts.scale
    2 Mar 31 22:38 /usr/X11R6/lib/X11/fonts/local/fonts.dir
 6270 Mar 31 22:38 /usr/X11R6/lib/X11/fonts/misc/fonts.alias
19014 Mar 31 22:38 /usr/X11R6/lib/X11/fonts/misc/fonts.dir

but even after unpacking XFree86-base-fonts-4.2.0-6.52.i386.rpm with
rpm2cpio and cpio various files, like for example.../Speedo/fonts.scale,
are nowhere to be found and ...Speedo/fonts.dir is 2 bytes long.

Version-Release number of selected component (if applicable):
XFree86-base-fonts-4.2.0-6.52
Comment 1 Mike A. Harris 2002-04-20 18:42:02 EDT
These issues are already fixed in RAWHIDE.  I think this one is a candidate
for the most frequent bug dupe award.  ;o)
Comment 2 Michal Jaegermann 2002-04-24 16:02:09 EDT
> These issues are already fixed in RAWHIDE.

Hm, if you say so.  I got around at last to install X from RAWHIDE and
immediately got on checks:

XFree86-base-fonts-4.2.0-7
missing    /usr/X11R6/lib/X11/fonts/100dpi/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/75dpi/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/CID/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/Speedo/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/Type1/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/local/encodings.dir
missing    /usr/X11R6/lib/X11/fonts/local/fonts.dir
missing    /usr/X11R6/lib/X11/fonts/misc/encodings.dir
XFree86-cyrillic-fonts-4.2.0-7
missing    /usr/X11R6/lib/X11/fonts/cyrillic/encodings.dir
It is likely not a very big deal but these files are listed by rpm, with
some exceptions (like ../fonts/local/...) with non-zero sizes, and are
not present neither in an archive nor created by %post scripts.

Yes, various fonts.dir and fonts.alias files do show up.

Note You need to log in before you can comment on or make changes to this bug.