This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 638958 - erro downloading package
erro downloading package
Status: CLOSED DUPLICATE of bug 638922
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.7
All Linux
low Severity medium
: rc
: ---
Assigned To: James Antill
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-30 09:43 EDT by Ed Gallagher
Modified: 2013-01-10 05:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-30 09:57:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ed Gallagher 2010-09-30 09:43:56 EDT
Component: pirut
Summary: TB7d428655 rhnplugin.py:319:_getFile:RepoError: failed to retrieve repodata/208e0e2bcdbffac4b526cb79a5e4e7252382a953-updateinfo.xml.gz from rhel-i386-server-5
error was [Errno -1] Metadata file does not match checksum

Traceback (most recent call last):
  File "/usr/sbin/pup", line 617, in ?
    main()
  File "/usr/sbin/pup", line 613, in main
    pup.run()
  File "/usr/sbin/pup", line 451, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 291, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 347, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 367, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1484, in retrieveMD
    return self._retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1524, in _retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 319, in _getFile
    raise yum.Errors.RepoError, \
RepoError: failed to retrieve repodata/208e0e2bcdbffac4b526cb79a5e4e7252382a953-updateinfo.xml.gz from rhel-i386-server-5
error was [Errno -1] Metadata file does not match checksum

Local variables in innermost frame:
e: [Errno -1] Metadata file does not match checksum
url: None
text: rhel-i386-server-5/updateinfo
self: rhel-i386-server-5
cache: False
reget: None
relative: repodata/208e0e2bcdbffac4b526cb79a5e4e7252382a953-updateinfo.xml.gz
start: None
checkfunc: (<bound method RhnRepo.checkMD of <rhnplugin.RhnRepo object at 0x86b7c8c>>, ('updateinfo',), {})
copy_local: 1
end: None
local: /var/cache/yum/rhel-i386-server-5/208e0e2bcdbffac4b526cb79a5e4e7252382a953-updateinfo.xml.gz
Comment 1 James Antill 2010-09-30 09:57:48 EDT

*** This bug has been marked as a duplicate of bug 638922 ***

Note You need to log in before you can comment on or make changes to this bug.