Bug 63896 - missing module bsd_comp
Summary: missing module bsd_comp
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel
Version: 1.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-20 21:44 UTC by Need Real Name
Modified: 2015-01-04 22:01 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-12-08 06:59:44 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-04-20 21:44:29 UTC
Description of Problem:
After starting pppd, modprobe complains about being unable to find a module
named ppp-compress-21. I figured out this should be aliased to bsd_comp, but
doing so doesn't make it work, because the file bsd_comp.o is missing from
/lib/modules/2.4.18-0.22/kernel/drivers/net/.

Version-Release number of selected component (if applicable):
kernel-2.4.18-0.22

How Reproducible:
every time

Steps to Reproduce:
1. add the line 'alias ppp-compress-21 bsd_comp' to /etc/modules.conf.
2. start pppd over a telephone line (may work with other setups too; I don't know.

Actual Results:
A line in /var/log/messages that says 'modprobe: Can't locate module
ppp-compress-21'.

Expected Results:
No complaints from pppd.

Additional Information:

Comment 1 Need Real Name 2002-05-21 07:38:19 UTC
Same for 7.3 and its update:
* kernel-2.4.18-3.i686.rpm
* kernel-2.4.18-4.i686.rpm

Comment 2 Arjan van de Ven 2002-05-21 08:18:08 UTC
the bsd_comp module is rather buggy and is disabled as a result.


Comment 3 Need Real Name 2002-05-28 21:53:45 UTC
I've also seen this on 7.3 (Both Kernels 2.4.18-3 & 2.4.18-4) I checked the
kernel config files and confirmed that in all the config files this option was
disabled. Any idea if this will get fixed?

Comment 4 Sepp Rudel 2003-06-11 11:24:48 UTC
Arjan, could you please eloborate a bit more about the state of bsd_comp, how
buggy it actually is? What's the main problem? Is there any point to enable it
in any situation?

Comment 5 Davide Bolcioni 2004-01-17 16:11:39 UTC
Of course, setting

  alias ppp-compress-21 off # See RedHat Bugzilla 63896

in modules.conf gets rid of the message for us paranoid types.

Comment 6 Dave Jones 2004-12-08 06:59:44 UTC
RHL era bug - closing due to end of life.


Note You need to log in before you can comment on or make changes to this bug.