Bug 638978 - sshd segfaults before password prompt
sshd segfaults before password prompt
Status: CLOSED DUPLICATE of bug 639048
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-30 10:30 EDT by Tomáš Bžatek
Modified: 2015-03-03 17:53 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-30 13:59:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of the segfaulting process (55.45 KB, application/octet-stream)
2010-09-30 10:30 EDT, Tomáš Bžatek
no flags Details

  None (edit)
Description Tomáš Bžatek 2010-09-30 10:30:13 EDT
Created attachment 450772 [details]
strace of the segfaulting process

Description of problem:
sshd crashes before asking for password. Looks to be working with -8/-7 or older.

Version-Release number of selected component (if applicable):
openssh-5.6p1-9.fc15.x86_64
audit-libs-2.0.4-4.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1. ssh localhost
2. accept unknown key warning
  
Actual results:
no password prompt,
sshd[4441]: segfault at 58258880 ip 00007feb565a8c58 sp 00007fff81415520 error 4 in libaudit.so.1.0.0[7feb565a2000+16000]

Additional info:
I was unable to grab a backtrace, attaching to sshd and setting "set follow-fork-mode child" won't stop on segfault and I only get "Program exited with code 0377."
No abrt here (various reasons), debugging hints welcome, already reported the gdb issue to jkratochvil.

So attaching a strace report instead.
Comment 1 John Ellson 2010-09-30 12:12:40 EDT
Me too.   Message on server console when trying to ssh from clinet.

   sshd[1409]: segfault at ffffffff830b7830 ip 00007f9881a8dc58 sp 00007fffd3faddd0 error 4 in libaudit.so.1.0.0[7f9881a87000+16000]
   
Problem goes away with downgrade to: openssh-5.6p1-8.fc15.x86_64.rpm
Doesn't seem to happen on i686.
Comment 2 Kamil Dudka 2010-09-30 13:59:56 EDT

*** This bug has been marked as a duplicate of bug 639048 ***

Note You need to log in before you can comment on or make changes to this bug.