This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 63903 - /etc/rc.d/init.d/network starts network interfaces when it should not
/etc/rc.d/init.d/network starts network interfaces when it should not
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-21 04:32 EDT by Manfred Hollstein
Modified: 2014-03-16 22:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 15:52:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manfred Hollstein 2002-04-21 04:32:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311

Description of problem:
Configuring network interfaces using redhat-config-network emits lines like this

  ONBOOT='no'

into the generated ifcfg-* files. Note that it's using the ' characters as
brackets aroung the variable's value! When /etc/rc.d/init.d/network is egrep'ing
through those ifcfg-* files during boot, it's however searching for

  "ONBOOT=\"?[Nn][Oo]\"?"

See the problem? The regex is wrong, in that it won't find the pattern in the
files generated by redhat-config-network. The regex should be this instead:

  "ONBOOT=['\"]?[Nn][Oo]['\"]?"

This will successfully find the following patterns:

  ONBOOT=no
  ONBOOT='no'
  ONBOOT="NO"


Version-Release number of selected component (if applicable):
initscripts-6.65-1

How reproducible:
Always

Steps to Reproduce:
1.Start redhat-config-network and configure a network device to *not* load ONBOOT
2.Save changes and reboot
3.Watch the messages and you'll see that the i/f _will_ be started!
	

Actual Results:  The interface will be started.

Expected Results:  The interface should not be started, of course.

Additional info:
Comment 1 Bill Nottingham 2002-04-21 15:11:28 EDT
The interface will not actually be started because 'boot' is passed to ifup,
which will do the right thing. It's just a weird display issue.
Comment 2 Bill Nottingham 2005-09-29 15:52:40 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.