Bug 639058 - cmake & gdk-pixbuf split
Summary: cmake & gdk-pixbuf split
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cmake
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-30 17:38 UTC by Jean-Eudes ONFRAY
Modified: 2010-11-29 19:22 UTC (History)
5 users (show)

Fixed In Version: cmake-2.8.2-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-08 10:15:16 UTC
Type: ---


Attachments (Terms of Use)

Description Jean-Eudes ONFRAY 2010-09-30 17:38:03 UTC
Description of problem:
The gdk-pixbuf library was split off from core GTK in 2.21 so it could be used
separately by people outside GTK.  FindGTK doesn't adds it to the
library/include list.

Version-Release number of selected component (if applicable):
cmake-2.8.2-2.fc14.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Upstream has this patch
http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=c1675951a013aadbdc472d323c4ff4efb80a09fa

Comment 1 Orion Poplawski 2010-10-06 16:59:34 UTC
How critical is this?  Can we just wait for 2.8.3?  There are a fair amount of changes to FindGTK2.cmake between 2.8.2 and 2.8.3.

Comment 2 Jean-Eudes ONFRAY 2010-10-07 12:16:31 UTC
No problem for me, I can wait if 2.8.3 is pushed to F14.

Currently any source that require gtk/gtk.h fail to compile with the following error:
In file included from /usr/include/gtk-2.0/gdk/gdkcairo.h:28:0,
                 from /usr/include/gtk-2.0/gdk/gdk.h:33,
                 from /usr/include/gtk-2.0/gtk/gtk.h:32,
                 from /home/user/test.h:5,
                 from /home/user/test.cpp:5:
/usr/include/gtk-2.0/gdk/gdkpixbuf.h:37:35: fatal error: gdk-pixbuf/gdk-pixbuf.h: No such file or directory

So IMHO it can be considered critical as any gtk app will not compile at all with cmake.

The current workaround is to append /usr/include/gdk-pixbuf-2.0 to GTK2_GDK_INCLUDE_DIR in CMakeCache.txt

Comment 3 Fedora Update System 2010-10-07 22:13:09 UTC
cmake-2.8.2-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/cmake-2.8.2-3.fc14

Comment 4 Jean-Eudes ONFRAY 2010-10-08 10:15:16 UTC
New package tested: everything builds fine.

Closing this bug now, dunno if I should choose RAWHIDE or NEXTRELEASE.

Thanks a lot Orion for such responsiveness.

PS: I could not add Karma to Bodhi, will try again later.

Comment 5 Fedora Update System 2010-10-28 06:16:24 UTC
cmake-2.8.2-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Colin Adams 2010-11-27 15:33:02 UTC
I have cmake-2.8.2-3.fc14.x86_64 installed, yet I am seeing this problem.

Comment 7 Orion Poplawski 2010-11-29 19:22:47 UTC
(In reply to comment #6)
> I have cmake-2.8.2-3.fc14.x86_64 installed, yet I am seeing this problem.

You have gtk2-devel and gdk-pixbuf2-devel installed?  Works for me.  Will need more details otherwise.


Note You need to log in before you can comment on or make changes to this bug.