Bug 63911 - CVS crash if .cvspass not accessible
Summary: CVS crash if .cvspass not accessible
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cvs   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-21 19:00 UTC by Itai Nahshon
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 19:04:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suggested patch (apply after cvs-1.11.1p1-cvspass.patch) (619 bytes, patch)
2002-04-21 19:03 UTC, Itai Nahshon
no flags Details | Diff

Description Itai Nahshon 2002-04-21 19:00:40 UTC
Description of Problem:    
Cvs (client side when using pserver) is crashing if the .cvspass  
file is not accessible.  
   
Version-Release number of selected component (if applicable):    
cvs-1.11.1p1-7   
   
How Reproducible:    
The easy way is to change the HOME environment variable to a  
non-existent or unreadable directory. Then try any cvs  
command that tries to access a pserver.  
  
Same thing has happened when I tried a cvs command from  
sudo (it does not change $HOME, so the target user cannot 
access .cvspass). 
  
    
Actual Results:  
    Segmentation fault (core dumped)  
  
Expected Results:    
    (error message)  
    
Additional Information:  
  The problem is in cvs-1.11.1p1-cvspass.patch (fromn the RedHat SRPM):  
+       fp = CVS_FOPEN (passfile, "w");  
+       fclose (fp);  
  If the fopen failed then the fclose will segfault.

Comment 1 Itai Nahshon 2002-04-21 19:03:04 UTC
Created attachment 54804 [details]
Suggested patch (apply after cvs-1.11.1p1-cvspass.patch)

Comment 2 Miloslav Trmač 2004-10-18 19:04:39 UTC
cvs-1.11.17-cvspass.patch contains this fix.


Note You need to log in before you can comment on or make changes to this bug.