Bug 639258 - Can't reload modules
Summary: Can't reload modules
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: irssi
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Filip Holec
URL:
Whiteboard:
Keywords: EasyFix, Patch
Depends On: 639260
Blocks: 1007420
TreeView+ depends on / blocked
 
Reported: 2010-10-01 09:26 UTC by Miroslav Vadkerti
Modified: 2018-10-16 09:18 UTC (History)
5 users (show)

(edit)
Previously it was possible to unload static modules. As these modules are static it wasn't actually unloaded but it was only made unavailable. After the unload action was completed these modules can be reactivated only by irssi restart. It is odd behaviour, thus the unload action was blocked on the static modules. Now only the dynamic modules can be unloaded.
Clone Of:
: 639260 1007420 (view as bug list)
(edit)
Last Closed: 2012-08-15 16:06:01 UTC


Attachments (Terms of Use)
Patch for disabling unload of static modules from UI (1.01 KB, patch)
2010-10-12 13:19 UTC, Jaroslav Škarvada
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1171 normal SHIPPED_LIVE irssi bug fix update 2012-08-15 20:05:30 UTC

Description Miroslav Vadkerti 2010-10-01 09:26:09 UTC
Description of problem:
In the latest irssi in RHEL6 i cannot reload any module after I unloaded it. When I restart irssi some modules ate auto-loaded. Unloading any module has no affect on my irssi perl scripts though (what is strange)

Version-Release number of selected component (if applicable):
irssi-0.8.15-3.el6

How reproducible:
100%

Steps to Reproduce:
1. start irssi
2. check loaded modules
/load
Module               Type    Submodules
core                 static  core irc fe fe-irc fe-text
dcc                  static  irc fe-irc
flood                static  irc
notifylist           static  irc fe-irc
perl                 static  core fe
3. unload module (e.g. perl)
/unload perl
4. verify perl module is gone
/load
Module               Type    Submodules
core                 static  core irc fe fe-irc fe-text
dcc                  static  irc fe-irc
flood                static  irc
notifylist           static  irc fe-irc
5. try to load module back
/load perl
-!- Irssi: Error loading module perl/core: /usr/lib64/irssi/modules/libperl_core.so: cannot open shared object file: No such file or directory
  
Actual results:
Can't load module

Expected results:
Module can be reloaded

Additional info:

Comment 1 Jaroslav Škarvada 2010-10-12 13:19:50 UTC
Created attachment 452961 [details]
Patch for disabling unload of static modules from UI

This is one of possible solutions. Other (probably better and of course harder)
solution is adding support for static modules reloading.

Comment 2 Jaroslav Škarvada 2010-10-12 13:20:29 UTC
Forwarded to upstream bugzilla:

http://bugs.irssi.org/index.php?do=details&task_id=774

Comment 3 Jaroslav Škarvada 2010-10-14 17:06:37 UTC
> Unloading any module has no affect on my irssi perl scripts though 
> (what is strange)
> 
Seems that static modules can not be unloaded thus the patch proposed in comment 1 should be enough.

Comment 5 Suzanne Yeghiayan 2011-02-15 21:43:21 UTC
This issue was proposed for RHEL 6.1 FasTrack but did not get resolved in time.
It has been moved to RHEL 6.2 FasTrack.

Comment 12 Jaroslav Škarvada 2012-07-16 09:04:11 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously it was possible to unload static modules. As these modules are static it wasn't actually unloaded but it was only made unavailable. After the unload action was completed these modules can be reactivated only by irssi restart. It is odd behaviour, thus the unload action was blocked on the static modules. Now only the dynamic modules can be unloaded.

Comment 16 errata-xmlrpc 2012-08-15 16:06:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1171.html


Note You need to log in before you can comment on or make changes to this bug.