Bug 639259 - Multiple same specifications for /etc/NetworkManager/dispatcher\.d(/.*)
Multiple same specifications for /etc/NetworkManager/dispatcher\.d(/.*)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-01 05:29 EDT by Radek Bíba
Modified: 2012-10-15 10:16 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-2.4.6-287.el5
Doc Type: Bug Fix
Doc Text:
Due to an error in a SELinux policy, messages similar to the following could be written to the /var/log/messages log file: restorecon: /etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /etc/NetworkManager/dispatcher\.d(/.*). These updated packages correct this error, and the above message no longer appears in the log.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 16:50:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2010-10-01 05:29:58 EDT
Description of problem:
The following messages are in my log file on my machine running RHEL 5.6 nightly:

yum: Updated: selinux-policy-2.4.6-285.el5.noarch
yum: Updated: gsl-devel-1.13-3.el5.i386
dbus: avc:  received policyload notice (seqno=4)
setfiles: /etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /etc/NetworkManager/dispatcher\.d(/.*).
restorecon: /etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /etc/NetworkManager/dispatcher\.d(/.*).
restorecon: /etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /etc/NetworkManager/dispatcher\.d(/.*).
yum: Updated: selinux-policy-targeted-2.4.6-285.el5.noarch
...

and then the message about multiple same specification occurs every now and then, mostly from ssh, kinit, and rpm.

Version-Release number of selected component (if applicable):
selinux-policy-2.4.6-285.el5

How reproducible:
I'm not really sure, but it appears that this message is printed every time a command that has something to do with selinux is executed. As a reproducer, I think just `matchpathcon /etc/yum.repos.d` will do.

 
Actual results:
/var/log/messages is spammed. I don't know if it has any other consequences.

Expected results:
Silence

Additional info:
# grep ^/etc/NetworkManager/dispatcher /etc/selinux/targeted/contexts/files/file_contexts
/etc/NetworkManager/dispatcher.d(/.*)?  system_u:object_r:bin_t:s0
/etc/NetworkManager/dispatcher\.d(/.*)  system_u:object_r:NetworkManager_initrc_exec_t:s0
/etc/NetworkManager/dispatcher\.d(/.*)  system_u:object_r:NetworkManager_initrc_exec_t:s0
Comment 5 Miroslav Grepl 2010-10-14 04:41:58 EDT
Fixed in selinux-policy-2.4.6-287.el5.noarch
Comment 9 Jaromir Hradilek 2011-01-05 11:21:49 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Due to an error in a SELinux policy, messages similar to the following could be written to the /var/log/messages log file:

  restorecon: /etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /etc/NetworkManager/dispatcher\.d(/.*).

These updated packages correct this error, and the above message no longer appears in the log.
Comment 11 errata-xmlrpc 2011-01-13 16:50:36 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0026.html

Note You need to log in before you can comment on or make changes to this bug.