Bug 639391 - Broken dependency: spacewalk-certs-tools-1.1.1-2.1.fc14.noarch requires spacewalk-backend-libs >= 0:0.8.28
Broken dependency: spacewalk-certs-tools-1.1.1-2.1.fc14.noarch requires space...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spacewalk-certs-tools (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
AcceptedNTH repoclosure_hash:62fe5095...
:
Depends On:
Blocks: F14Blocker/F14FinalBlocker 639440 f14-repo-nonmedia
  Show dependency treegraph
 
Reported: 2010-10-01 12:00 EDT by Bill Nottingham
Modified: 2014-03-16 23:25 EDT (History)
6 users (show)

See Also:
Fixed In Version: spacewalk-certs-tools-0.7.2-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 639440 (view as bug list)
Environment:
Last Closed: 2010-10-19 05:12:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2010-10-01 12:00:57 EDT
Description of problem:

See subject.

Version-Release number of selected component (if applicable):

1.1.1-2.1.fc14
Comment 1 Stephen Herr 2010-10-01 14:25:47 EDT
Don't know how high the priority on this should be, but this is actively blocking customers from installing RHN Proxy through the webui. This package is required to create the ssl tarball that the web installer requires.
Comment 2 Stephen Herr 2010-10-01 14:26:36 EDT
Oh, didn't notice that this is a fedora bug, I will clone for RHEL 5.
Comment 3 Adam Williamson 2010-10-01 15:45:06 EDT
This was discussed during the 2010-10-01 blocker review meeting. We
conditionally accept it as a blocker on the basis of a proposed new criterion
which requires there to be no unresolved dependencies or unintentional
conflicts in any package (not just packages on the media) for Final release.
See http://lists.fedoraproject.org/pipermail/test/2010-October/094302.html .
Comment 4 Adam Williamson 2010-10-01 15:50:35 EDT
seems like the dep is stuck in review: https://bugzilla.redhat.com/show_bug.cgi?id=612581
Comment 5 Miroslav Suchý 2010-10-04 04:17:59 EDT
Yes, and the review is taking too much long and will need a lot of work. ETA is probably few months.
I would suggest to delete the F14 and F15 build and revert to spacewalk-certs-tools-0.7.2-1, which does not have this dependency.
Once I pass through the review with spacewalk-backend, I will update spacewalk-certs-tools.
I'm not sure what is correct process for this? File rel-eng ticket to delete those builds from koji?
Comment 6 Adam Williamson 2010-10-04 15:47:03 EDT
'unmaking' builds like this is frowned upon as it's impolite to those who've already installed the newer packages. The usual way to do this is to push a higher-numbered build which simply reverts the changes. If you need to revert to an older upstream version, you'd have to add an Epoch. If this build were only in -testing we might consider it cleaner to unpush the build than to add an Epoch, but since it went to -stable, I rather think we'd prefer you to push a 0.7.2-2 with an Epoch. Bill, WDYT?
Comment 7 Bill Nottingham 2010-10-04 15:51:51 EDT
Yeah, an epoch is probably best. Or a new build that has the Requires: removed, although the implication is that a build of that sort would be non-functional?
Comment 8 Miroslav Suchý 2010-10-05 11:27:17 EDT
> it's impolite to those who've already installed the newer packages

They could not install it. Not using yum.
Only possibility is rpm --nodeps, which is not standard work flow.

> although the implication is that a build of that sort would be non-functional

Which will does not matter since this is part of Spacewalk server and we have not all part in Fedora yet. So unless you have external repo, you will probably have not much use for this package.
Comment 9 Miroslav Suchý 2010-10-07 10:05:11 EDT
I revert to 0.7.2 and bumped up epoch, although I do not like it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=2520150
Comment 10 Fedora Update System 2010-10-07 10:10:57 EDT
spacewalk-certs-tools-0.7.2-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/spacewalk-certs-tools-0.7.2-1.fc14
Comment 11 Fedora Update System 2010-10-07 15:53:55 EDT
spacewalk-certs-tools-0.7.2-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update spacewalk-certs-tools'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/spacewalk-certs-tools-0.7.2-1.fc14
Comment 12 Adam Williamson 2010-10-08 15:04:52 EDT
Dependency and conflict issues are automatically accepted as nice-to-have.
Comment 13 Adam Williamson 2010-10-12 20:24:38 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Sandro Mathys 2010-10-14 16:56:44 EDT
I confirm that spacewalk-certs-tools-0.7.2-1.fc14, i.e. 1:0.7.2-1 fixes this issue.
Comment 15 Fedora Update System 2010-10-19 05:12:17 EDT
spacewalk-certs-tools-0.7.2-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.