Bug 639470 - remove samba dependency on perl
remove samba dependency on perl
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraServerTracker
  Show dependency treegraph
 
Reported: 2010-10-01 16:20 EDT by Daniel Mach
Modified: 2013-02-12 00:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-12 00:05:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Mach 2010-10-01 16:20:38 EDT
There are perl scripts in /usr/share/doc:
/usr/share/doc/samba-3.5.5/LDAP/convertSambaAccount
/usr/share/doc/samba-3.5.5/LDAP/ol-schema-migrate.pl
/usr/share/doc/samba-3.5.5/misc/adssearch.pl
/usr/share/doc/samba-3.5.5/misc/check_multiple_LDAP_entries.pl
/usr/share/doc/samba-3.5.5/misc/cldap.pl
/usr/share/doc/samba-3.5.5/misc/swat.pl
/usr/share/doc/samba-3.5.5/misc/wall.perl
/usr/share/doc/samba-3.5.5/printer-accounting/acct-sum
/usr/share/doc/samba-3.5.5/printer-accounting/hp5-redir
/usr/share/doc/samba-3.5.5/printer-accounting/lp-acct

These scripts do not work with additional perl modules installed, so I think the perl dependency could be removed completely.

This is probably related to bug 473051.
Comment 1 Fedora Admin XMLRPC Client 2010-10-08 10:43:43 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Guenther Deschner 2010-11-01 11:38:21 EDT
Actually we explicitly filter out the dependency to all the other perl modules so that users can easily get the full documentation package (including some perl example scripts) in one package. Once they really have a need for one of the perl scripts figuring out which additional modules are required is easy. I don't think we should change that. Sounds ok ?
Comment 3 Jason Tibbitts 2011-03-21 18:14:25 EDT
I think the point of this ticket is to point out that while the dependencies for the Perl modules are indeed gone, the dependency on /usr/bin/perl is still there.  As far as I can tell, nothing in that package actually needs perl except for those few documentation files, and so as long as you're filtering Perl dependencies, you might as well go all the way and filter /usr/bin/perl too.  

Unfortunately that isn't completely trivial since you can't just add it to the existing filter-requires-samba.sh, though it should be possible using the new RPM dependency filtering mechanism.  I'd provide a patch if only that were documented.
Comment 4 Daniel Mach 2011-03-24 09:39:23 EDT
Sorry for not responding for a while.
I spoke to perl maintainer and she suggested to run 'chmod -x' on all documentation files (which should help) or use following macro:
%filter_provides_in %{_docdir}

see: https://fedoraproject.org/wiki/Packaging:AutoProvidesAndRequiresFiltering
Comment 5 Guenther Deschner 2011-04-06 11:18:08 EDT
We will address this in future fedora
Comment 6 Fedora Update System 2013-01-30 12:30:03 EST
samba-4.0.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/samba-4.0.2-1.fc18
Comment 7 Fedora Update System 2013-02-01 11:26:44 EST
Package samba-4.0.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing samba-4.0.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1654/samba-4.0.2-1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-02-12 00:05:59 EST
samba-4.0.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.