Bug 639522 - FutureFeature: Bridging support in Network manager would make life MUCH EASIER
FutureFeature: Bridging support in Network manager would make life MUCH EASIER
Status: CLOSED DUPLICATE of bug 199246
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-01 23:49 EDT by Kronos003
Modified: 2010-10-07 00:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-07 00:32:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kronos003 2010-10-01 23:49:54 EDT
Description of problem:
I was hoping that Bridging support would make it into NetworkManager for the F13 release. not sure what happened. As of now to guarantee full functionality of all guests on my laptop(any guests which depend on the 'default' NAT network still work along side the guests which need access to the 'bridged' network) i have to run this script while all guests which depend on 'default' are OFF:


to have a functioning br0, i have to give up easy access to wlan0 and the like while br0 is up. (to get wifi back i have to reboot (at least that is the answer for now - i haven't researched it further))


+++ code +++
virsh net-destroy default # still points to wlan0 which is about to go away
service NetworkManager stop
service network restart
virsh net-start default # now it will point to 'br0' which now exists
--- code ---

This script has drawback of not allowing me to have easy access to any wifi networks via wlan0 while running the bridging setup. i imagine that if i REALLY wanted to i could wing it manually, but i remember the days before NetworkManager. wifi was almost unusable - an extreme PAIN to set up from what i remember(i bypassed messing with wlan0 configuration  by using a http-configured ethernet bridge on eth0 - which i still have and STILL USE for bridging in some environments). there has to be an easier way.


Hopefully fairly easy to implement: (as in PLEASE PLEASE PLEASE - we/I need this)
Bridging support in network manager was promised for the F13 release, but then dropped. is there any hope of seeing this in F14 or (more likely) F15? I could really use that feature as it would be most excellent to have full and easy control of my wlan0 interface even while im using guests which are bridged to eth0, or hey maybe even bridged to wlan0? though bridging to eth0 while still retaining control of wlan0 would be MOST EXCELLENT - especially if i could do it without first running a setup script. 


likely a pie in the sky pipe dream: (as in would be nice, but not as badly needed)
It would be even more awesome if it enabled me to (by some miracle) bridge to a wifi interface AND it was able to cope(maintain internet connectivity to the vms) with connecting to first one network(ssid) then another without first powering down the vm or restarting the virtual-network in question(i think a lot of users would be THRILLED if that could happen with that amount of flexibility).
Comment 1 Dan Williams 2010-10-07 00:32:14 EDT
Bridging is planned.  Unfortunately bridging may not ever work with wifi because wifi is special (3 and 4-address frames) while ethernet uses only 2-address frames.  Thus you're missing one address when bridging from ethernet -> wifi.

*** This bug has been marked as a duplicate of bug 199246 ***

Note You need to log in before you can comment on or make changes to this bug.