This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 639532 - Wrong rendering of several gtk-themes with proprietary nvidia driver
Wrong rendering of several gtk-themes with proprietary nvidia driver
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Benjamin Otte
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-02 03:30 EDT by hannes
Modified: 2010-11-17 17:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-15 15:15:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description hannes 2010-10-02 03:30:57 EDT
Description of problem:
There are several glitches in parts of the gtk theme. I'll attach a screenshot so that one could better see what I mean.
http://hannes.fedorapeople.org/Screenshot%20-%2009302010%20-%2006:21:20%20PM.png
Locations of glitches:
- open a new tab button in firefox
- upper panel: cpu usage progressbars
- lower panel: window list

Version-Release number of selected component (if applicable):
rpm -qa| grep cairo
pycairo-1.8.8-2.fc14.x86_64
cairo-1.10.0-1.fc14.i686
cairo-1.10.0-1.fc14.x86_64
cairomm-1.9.1-1.fc14.x86_64

How reproducible:
It occurs with clearlooks and murrine themes on a proprietary nvidia driver. I tried various versions of the nvidia driver 253 and 260 both installed via rpm and the proprietary installer. The problem doesn't appear with Nodoka so I use that at the moment.
 



Additional info:
There are several bugs on the ubuntu launchpad:
https://bugzilla.gnome.org/show_bug.cgi?id=624805
https://bugs.launchpad.net/ubuntu/+source/gtk2-engines-murrine/+bug/605979

I am not quite sure if it is the same problem but at least a very similar one.
Comment 1 Benjamin Otte 2010-10-15 15:15:17 EDT
So we figured out on IRC that this was caused by a broken nvidia driver. So I'm closing this.
Comment 2 Artem S. Tashkinov 2010-11-17 17:35:20 EST
Or use cairo with a proper patch http://www.mediafire.com/?bk8b3gjr3zccbub

Note You need to log in before you can comment on or make changes to this bug.