Bug 63954 - Upgrade to 7.2 when kernel version does not need upgrade kills LILO but doesn't install GRUB.
Upgrade to 7.2 when kernel version does not need upgrade kills LILO but doesn...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-22 12:39 EDT by Thomas Meyer
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-22 12:39:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Meyer 2002-04-22 12:39:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-31 i586)

Description of problem:
Due to a previous kernel-only upgrade my 7.1 installation was already at
2.4.9-31. When I upgraded to 7.2, anaconda recognized that the kernel did not
need to be upgraded.  Therefore, it would not allow GRUB to be installed.  But
it had already renamed or deleted /etc/lilo.conf, so when I tried to boot the
machine after the installation the boot loader failed.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install 7.1,
2. Upgrade the kernel to 2.4.9-31
3. Upgrade to 7.2, choosing to install GRUB.
	

Actual Results:  When I tried to reboot I got "LI" in the upper left corner of
the screen and the machine hung.

Expected Results:  A boot loader screen should have appeared.

Additional info:
Comment 1 Jeremy Katz 2002-04-23 18:53:57 EDT
This is fixed in Skipjack by changing the way we handle the boot loader on upgrades.

Note You need to log in before you can comment on or make changes to this bug.