Bug 63955 - Large image caused total system crash
Large image caused total system crash
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gimp (Show other bugs)
9
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
ftp://sdcd.gsfc.nasa.gov/pub/EARTHVIZ/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-22 12:48 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-21 12:40:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-04-22 12:48:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc1)
Gecko/20020417

Description of problem:
I opend a 500Mb image in the gimp, it caused an immediate reboot

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.OPen large image with the GIMP
2.watch it crash
3.
	

Actual Results:  System crashed and rebooted

Expected Results:  open image

Additional info:

I have a KT266a motherboard with 256MB of ram. The image was over 500MB and can
be found at the above URL (photo of earth). I downloaded it to my hard drive and
opened it from there.
I don't actually know if it's a gimp crash or not.
Comment 1 Warren Togami 2002-04-28 00:07:27 EDT
What kernel version were you running at the time of the crash? 
 
Use "uname -a" 
Comment 2 Need Real Name 2002-04-29 17:09:11 EDT
2.4.18-0.13
Comment 3 Warren Togami 2002-04-29 21:26:52 EDT
Please re-test it after a full upgrade with up2date.  Especially make sure that
the kernel is upgraded.

Use "up2date -uf" to force a kernel upgrade along with the rest of the packages.
Comment 4 Need Real Name 2002-04-30 16:43:15 EDT
OK....
I updated my kernel to 2.4.18-0.22, and updated most other packages.
I open up the image in gimp. gimp opened most of it up before it brought my
system to a halt, not crash, just very slow due to lack of ram, as I expected it to.
BUT- you guys tell me if this is ok, I couldn't get to another terminal. I kept
hitting ctrl-alt-F2, nothing happened, I left and came back an hour later. I was
in a terminal window but the screen was filled up with gibberish ascii letters,
I figured out that I was at the login prompt and logged in as root blindly, the
told it to reboot.

after rebooting I couldn't login as a user, I even created a new user to login
as. I would enter username and password then it would bring me right back to the
login prompt.
ROOT was the only one that could login, I did lock up tty1 by doing s "su
username" to  then statx

some one suggested I run fsck on my /home partition. I ran fsck.ext3 -f
/dev/da2. no problems, then I ran fsck.ext3 -pf /dev/hda2 to be sure.

I rebooted and all is fine. I don't know what happened.

as for this bug I think it's probably closed....

Note You need to log in before you can comment on or make changes to this bug.