Bug 63956 - gdm does not start after clean install
gdm does not start after clean install
Product: Red Hat Public Beta
Classification: Retired
Component: gdm (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2002-04-22 13:07 EDT by Geert Noel
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-12-19 20:36:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Geert Noel 2002-04-22 13:07:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc1)

Description of problem:
I did a clean install and chose the graphical login. After booting, I get the
text login prompt. Starting gdm from the command line gives the message 'gdm
already running'. I am in runlevel 5.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. clean install with graphical login
2. login via text prompt
3. start gdm

Additional info:
Comment 1 Havoc Pennington 2002-04-22 14:24:53 EDT
Anything in syslog?

You're on virtual terminal 7?
Comment 2 Geert Noel 2002-04-22 15:13:15 EDT
I'm not in virtual terminal 7. In fact, pressing ctrl-alt-F7 doesn't do
anything. I have to start kdm to get X running.

Can't see anything in syslog, but I don't know whether I'm looking in the
correct file :~ I do get a logwatch mail about modules that couldn't be located
(ntfs, freentfs and several sound modules - probably due to my audigy) and about
insmod mousedev that failed because it already exists. I don't think any of that
is related though.
Comment 3 Havoc Pennington 2002-07-05 22:12:04 EDT
Was this still happening in 7.3?

Or if you try Limbo, is it happening there?

Any new details?
Comment 4 Pam Huntley 2002-07-08 13:36:44 EDT

I got a similar bug for 7.3.  gdm was starting, but reverting back to text mode.
 We had run Xconfigurator and checked inittab and everything. Turns out the ip
address was from dhcp, but the guy had entered a hostname anyways.  So when gdm
when to start, it couldn't authorize or whatever (that was in
/var/log/messages).  The guy was able to start x manually, but it also
complained about not being able to look up the hostname.  I added his hostname
to /etc/hosts, with the ip, and it worked.  gdm now starts up at boot.
 Not sure if that was a bad idea, pls let me know if there's a better way to
resolve this...
Comment 5 Geert Noel 2002-07-13 14:45:40 EDT
7.3 worked perfectly. I still get the insmod mousedev failed message, but the
mouse works correctly, so I don't know what the problem is.

I'll try limbo in a few days.
Comment 6 Havoc Pennington 2002-12-19 20:36:42 EST
Comments sound like this is fixed, reopen if still in 8.0.

Note You need to log in before you can comment on or make changes to this bug.