Bug 639604 - equalizer resets volume to maximum on every change
Summary: equalizer resets volume to maximum on every change
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio-equalizer
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Hicham HAOUARI
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-02 13:55 UTC by vikram goyal
Modified: 2011-01-13 23:35 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-01-13 23:33:11 UTC


Attachments (Terms of Use)

Description vikram goyal 2010-10-02 13:55:27 UTC
Description of problem:
Enabling or selecting any equalizer preset resets the volume to 100%

Version-Release number of selected component (if applicable):
pulseaudio-equalizer-2.7-3.fc13.noarch

How reproducible:
start pulseaudio-equalizer from menu or commandline. Set the volume to some
low level. Enable the equalizer or select a different preset will reset the volume to maximum

Steps to Reproduce:
1.start pulseaudio-equalizer from menu or commandline.
2.Set the volume to some low level.
3.Enable the equalizer or select a different preset
  
Actual results:
Volume gets reset to maximum which makes it difficult to use as speakers have to be switched off but then one cannot know if the selected preset is acceptable.

Expected results:
The volume should not get affected

Additional info:
Is it possible to make it dock-able something like volume control since this will make it extremely usable.
Thanks

Comment 1 Matt Chan 2010-10-05 23:28:46 UTC
I can confirm this bug. 

This seems reminiscent of the F9(?) bug in pulseaudio that would set the volume to 100% or higher when the system was resumed from suspend.

Could a pulseaudio dev weigh in on this issue?

Matt

Comment 2 Hicham HAOUARI 2010-10-05 23:36:36 UTC
This is a by design in the software itself, and not pulseaudio : The preamp slider acts as a volume control slider in the UI.

I contacted upstream for more insight before issuing a fix for this.

Comment 3 Fedora Update System 2011-01-04 00:10:09 UTC
pulseaudio-equalizer-2.7-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pulseaudio-equalizer-2.7-4.fc14

Comment 4 Fedora Update System 2011-01-04 00:10:24 UTC
pulseaudio-equalizer-2.7-4.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/pulseaudio-equalizer-2.7-4.fc13

Comment 5 Fedora Update System 2011-01-04 20:56:00 UTC
pulseaudio-equalizer-2.7-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pulseaudio-equalizer'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/pulseaudio-equalizer-2.7-4.fc14

Comment 6 Fedora Update System 2011-01-05 14:54:36 UTC
pulseaudio-equalizer-2.7-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pulseaudio-equalizer-2.7-5.fc14

Comment 7 Fedora Update System 2011-01-05 14:54:53 UTC
pulseaudio-equalizer-2.7-5.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/pulseaudio-equalizer-2.7-5.fc13

Comment 8 Fedora Update System 2011-01-13 23:33:04 UTC
pulseaudio-equalizer-2.7-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-01-13 23:35:52 UTC
pulseaudio-equalizer-2.7-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.