Bug 63975 - newgrp does not support dynamic groups properly
newgrp does not support dynamic groups properly
Status: CLOSED DUPLICATE of bug 14464
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-22 17:27 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-22 17:27:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-04-22 17:27:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-31 i686)

Description of problem:
newgrp will not allow unpriveleged users to change to a passworded group of
which they are not a member, even if they authenticate with the proper group
password.

Version-Release number of selected component (if applicable):
newgrp from: util-linux-2.11f-17
shadow from: shadow-utils-20000902-4

How reproducible:
Always

Steps to Reproduce:
As root:
   1. groupadd test
   2. gpasswd test  # Password: testing

As user:
   1. newgrp test   # Password: testing

Actual Results:  newgrp: Permission denied

Expected Results:  GID should have been changed to "test" and other groups
should have become secondaries.

Additional info:

newgrp from: util-linux-2.11f-17
shadow from: shadow-utils-20000902-4
Comment 1 Elliot Lee 2002-04-22 17:31:33 EDT

*** This bug has been marked as a duplicate of 14464 ***

Note You need to log in before you can comment on or make changes to this bug.