Bug 6398 - tcsh globbing is case insensitive
Summary: tcsh globbing is case insensitive
Status: CLOSED DUPLICATE of bug 6000
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-26 21:37 UTC by Bertil Askelid
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-10 20:18:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bertil Askelid 1999-10-26 21:37:04 UTC
I have a directory with the following:

   bertil> ls
   A  B  C  a  b  c

Globbing no longer works correctly in tcsh:

   bertil> echo $tcsh
   6.08.00
   bertil> echo [a-zA-Z]
   A a B b C c
   bertil> echo [A-Z]
   A a B b C c
   bertil> echo [a-z]
   a B b C c

It is even inconsistent as the "A" is missing on the last
line!

In a previous version of tcsh, the following was the result:

   kali:bertil> echo $tcsh
   6.07.01
   kali:bertil> echo [a-zA-Z]
   A B C a b c
   kali:bertil> echo [A-Z]
   A B C
   kali:bertil> echo [a-z]
   a b c

Comment 1 kevin lyda 1999-12-28 20:22:59 UTC
this is a duplicate of bug id 6000

Comment 2 kevin lyda 2000-01-01 22:09:59 UTC
there's a fix described in bug id 6000

Comment 3 Jeff Johnson 2000-01-10 20:18:59 UTC
*** This bug has been marked as a duplicate of 6000 ***


Note You need to log in before you can comment on or make changes to this bug.