Bug 63984 - runtest CC=gcc no longer works
runtest CC=gcc no longer works
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dejagnu (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-23 02:38 EDT by hjl
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version: 1.4.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 14:33:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch (1.16 KB, patch)
2002-04-25 14:42 EDT, hjl
no flags Details | Diff

  None (edit)
Description hjl 2002-04-23 02:38:07 EDT
"[A-Z0-9_-.]*=*" { # process makefile style args like CC=gcc, etc...
            if [regexp "^(\[A-Z0-9_-\]+)=(.*)$" $option junk var val] {
                set $var $val
                verbose "$var is now $val"
                append makevars "set $var $val;" ;# FIXME: Used anywhere?
                unset junk var val
            } else {
                send_error "Illegal variable specification:\n"

is not in /usr/share/dejagnu/runtest.exp. As the result, "make check"
doesn't work in binutils/ld.
Comment 1 hjl 2002-04-25 14:42:07 EDT
The problem is CC=gcc is processed at the first parse, instead of the second
one. I am
submitting a patch now.
Comment 2 hjl 2002-04-25 14:42:42 EDT
Created attachment 55325 [details]
A patch
Comment 3 hjl 2002-04-25 14:54:04 EDT
This bug has been fixed in the dejagnu cvs a few months ago:

revision 1.8
date: 2001/10/07 04:10:28;  author: rsavoye;  state: Exp;  lines: +5 -1
2001-10-06  Gwenole Beauchesne <gbeauchesne@mandrakesoft.com>

        * Check for Makefile style arguments in the second pass, but
        ignore them, so they don't become invalid arguments.

Please consider fixing it.

Note You need to log in before you can comment on or make changes to this bug.