Bug 639866 - docbook2man generates man pages which rpmlint does not like
Summary: docbook2man generates man pages which rpmlint does not like
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: docbook-utils
Version: 6.1
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ondrej Vasik
QA Contact: Filip Holec
URL:
Whiteboard:
Depends On: 639347
Blocks: 836169
TreeView+ depends on / blocked
 
Reported: 2010-10-04 09:00 UTC by Ondrej Vasik
Modified: 2016-04-18 10:20 UTC (History)
5 users (show)

Fixed In Version: docbook-utils-0.6.14-25.el6
Doc Type: Bug Fix
Doc Text:
Cause: Perl script used for generating manpages contained one typo. Consequence: Bad syntax of all manpages built docbook-utils. Even though this typo was in header, so it had no impact on the content, the manpages had invalid syntax. Fix: Perl script was fixed. Result: Manpages built by this new docbook-utils package will have correct manpage header syntax.
Clone Of: 639347
Environment:
Last Closed: 2012-10-02 10:08:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1321 normal SHIPPED_LIVE docbook-utils bug fix update 2012-10-02 14:08:01 UTC

Description Ondrej Vasik 2010-10-04 09:00:18 UTC
+++ This bug was initially created as a clone of Bug #639347 +++

Created attachment 451023 [details]
zif.sgml - the source for a manpage

Description of problem:
rpmlint complained about the manpage generated by docbook2man in this package review: https://bugzilla.redhat.com/show_bug.cgi?id=631763#c6

The warning was:
manual-page-warning /usr/share/man/man1/zif.1.gz 1: warning: `\"' not defined

The warning can be reproduced using a command like this:
gtbl < zif.1 | groff -mtty-char -Tutf8 -P-c -mandoc -mandoc -wmac >/dev/null
(where zif.1 was generated by docbook2man from the attached source)

groff does not like the first line in the file:
.\\" auto-generated by docbook2man-spec $Revision: 1.2 $

I believe the correct form would be:
.\" auto-generated by docbook2man-spec $Revision: 1.2 $

Version-Release number of selected component (if applicable):
docbook-utils-0.6.14-23.fc13.noarch

How reproducible:
always

Steps to Reproduce:
1. generate a manpage from the attached source using docbook2man
2. verify it using the command mentioned above (that's basically what rpmlint uses)
  
Actual results:
a warning is produced

Expected results:
no warnings

Comment 1 Suzanne Yeghiayan 2011-02-15 21:43:29 UTC
This issue was proposed for RHEL 6.1 FasTrack but did not get resolved in time.
It has been moved to RHEL 6.2 FasTrack.

Comment 12 errata-xmlrpc 2012-10-02 10:08:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1321.html


Note You need to log in before you can comment on or make changes to this bug.