Bug 639901 - Disappearing startup error messagebox
Disappearing startup error messagebox
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-04 06:07 EDT by Mads Kiilerich
Modified: 2012-04-30 11:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 11:14:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the mentioned log (31.42 KB, text/plain)
2010-10-04 06:07 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2010-10-04 06:07:41 EDT
Created attachment 451366 [details]
the mentioned log

For some reason I got a message box when trying to start eclipse:

    Eclipse
    An error has occurred. See the log file
    /home/mk/.eclipse/155965261/configuration/1286185574949.log.
    [Close]

That message is not alt-tabable (in Gnome), so when switching to an editor/command line for opening the logfile the messagebox seems to disappear.

I would expect eclipse to appear in the window list and be alt-tab-reachable if it displays any gui elements.

I would also expect such a fundamental messages to also be shown on stdout, especially with -debug.

This may not be a Fedora-specific problem, but it is a problem that causes that eclipse doesn't integrates as nice with Fedora as we would like.

(Starting with -clean fixed the problem. The original error log has been attached. It might be a problem when upgrading from f13, but I don't have enough evidence for reporting that as a bug.)

eclipse-platform-3.6.0-3.fc14.i686
Comment 1 Severin Gehwolf 2010-10-04 09:22:36 EDT
Could you start eclipse from a terminal like so:

$ eclipse -debug -consolelog

Could you attach the output you are getting on the console. Thanks!
Comment 2 Severin Gehwolf 2010-10-04 09:33:43 EDT
Ok sorry, please disregard my comment above. The logs you provided are sufficient. It looks like this is a problem related to some cached data when upgrading from 3.5.x to 3.6.x.

> I would also expect such a fundamental messages to also be shown on stdout,
> especially with -debug.

$ eclipse -debug -consolelog

should show the trace in the console.
Comment 3 Mads Kiilerich 2010-10-04 09:45:33 EDT
Note that I have been using the upstream pydev development "software repository" while running f13, but regularly uninstalled it and thus downgraded to the rpm-packaged pydev without any problems.
Comment 4 Alexander Kurtakov 2010-10-06 04:33:43 EDT
Downgrades are not supported and they are creating nasty side effects that noone has tested nor wants to test.
Comment 5 Alexander Kurtakov 2012-04-30 11:14:37 EDT
Closing as Fedora 14 is long dead. Please reopen if still reproducible with supported Fedora release.

Note You need to log in before you can comment on or make changes to this bug.