Bug 640133 - Fedora 14 does not boot on Mac Mini after installation from optical media (live and install)
Fedora 14 does not boot on Mac Mini after installation from optical media (li...
Status: CLOSED DUPLICATE of bug 503149
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-04 17:41 EDT by Eric Sokolowsky
Modified: 2010-10-04 21:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-04 21:45:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sokolowsky 2010-10-04 17:41:02 EDT
Description of problem:

Fedora 14 beta does not install correctly on new 2010 Mac Mini. The problem appears to be finding and booting grub after the installation is complete. This is a problem with both the live and install Fedora 14 Beta install media.

Version-Release number of selected component (if applicable):

How reproducible: always

Steps to Reproduce:
1. Boot the Fedora install media (live CD or install DVD).
2. Select either booting from MBR or boot partition. Other settings as desired.
3. When rebooting after installation, machine just hangs forever.
  
Actual results:

Machine just hangs.


Expected results:

Boot into Fedora.


Additional info:

I am able to boot into Fedora 14 on the mac mini hardware by first installing openSUSE 11.3 on /dev/sda1 (20GB partition), then installing Fedora 14 on /dev/sda2 (20GB partition), and using the boot menu on /dev/sda1 to boot fedora, copying the section from grub.conf in sda2 into menu.lst on sda1. The command that openSUSE uses to set up grub is "setup --stage2=/boot/grub/stage2 --force-lba (hd0) (hd0,0)". I suspect the "--force-lba" flag to be the difference.
Comment 1 Chris Lumens 2010-10-04 21:45:55 EDT

*** This bug has been marked as a duplicate of bug 503149 ***

Note You need to log in before you can comment on or make changes to this bug.