Bug 640136 - KPackageKit __crashes__ trying to install .deb packages
KPackageKit __crashes__ trying to install .deb packages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-04 18:17 EDT by Andrei ILIE
Modified: 2010-10-13 10:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-13 10:17:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrei ILIE 2010-10-04 18:17:20 EDT
Description of problem:
   KPackageKit crashes when instructed to install a .deb on Fedora 13. It seems like it doesn't validate first the files it tries to install.

Version-Release number of selected component (if applicable):
   0.6.0-2.fc13

How reproducible:
   always

Steps to Reproduce:
   1. From the Adobe site, download the Flash Player package (.deb flavour).
   2. Try to install it with the KPackageKit.
  
Actual results:
   KPackageKit crashes.

Expected results:
   KPackageKit should alert the user that Fedora only supports rpms. Afterwards, it should cleanly exit.
Comment 1 Rex Dieter 2010-10-04 20:08:39 EDT
This is probably one of those cases of "don't do that!"

Try kpackagekit-0.6.1 ?
https://admin.fedoraproject.org/updates/kpackagekit-0.6.1-1.fc13
Comment 2 Steven M. Parrish 2010-10-13 10:17:59 EDT
Yes it is a case of "Don't do that" but the newest version of kpackagekit 0.6.1 does fix the crash and you now get a warning message.

Note You need to log in before you can comment on or make changes to this bug.