Bug 64018 - compiling glibc rpm for --target athlon fails
Summary: compiling glibc rpm for --target athlon fails
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 9
Hardware: athlon Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-23 20:31 UTC by Wilton Wong
Modified: 2016-11-24 14:49 UTC (History)
1 user (show)

Fixed In Version: 2.3.2-27.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-17 17:15:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wilton Wong 2002-04-23 20:31:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
compiling glibc rpm for --target athlon fails because prelink is never
decompressed and libs aldo end up in /lib/i686 and not /lib/athlon

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -ba --target athlon glibc-2.2.5-....


Actual Results:  %build will fail at prelink portion

Expected Results:  sucessful compile and rpm build

Additional info:

change the lines in glibc.spec: 
<SNIP>
%ifarch i686
mkdir prelink
tar x --bzip2 -C prelink -f %{SOURCE2}
%endif
</SNIP>
to
<SNIP>
%ifarch i686 athlon
mkdir prelink
tar x --bzip2 -C prelink -f %{SOURCE2}
%endif
</SNIP>

and change the lines:
<SNIP>
%ifarch i686 athlon
rm -f $RPM_BUILD_ROOT%{_prefix}/%{_lib}/debug/{libc,libm,libpthread}[-.]*.so*
cp -a $RPM_BUILD_ROOT/%{_lib}/%{_target_cpu}/lib*.so*
$RPM_BUILD_ROOT%{_prefix}/%{_lib}/debug/
%endif
</SNIP>
to
<SNIP>
%ifarch i686 athlon
rm -f $RPM_BUILD_ROOT%{_prefix}/%{_lib}/debug/{libc,libm,libpthread}[-.]*.so*
cp -a $RPM_BUILD_ROOT/%{_lib}/i686/lib*.so* $RPM_BUILD_ROOT%{_prefix}/%{_lib}/debug/
%endif
</SNIP>

Comment 1 Ulrich Drepper 2003-04-17 17:15:40 UTC
The glibc .spec file doesn't contain these lines anymore.  It'll use an already
installed prelink package.


Note You need to log in before you can comment on or make changes to this bug.