Bug 64019 - trouble apparently in British/Canadian dictionaries
Summary: trouble apparently in British/Canadian dictionaries
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: aspell (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-23 20:54 UTC by Michal Jaegermann
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-26 23:52:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A file which shows an aspell error (40.65 KB, text/plain)
2002-04-23 20:56 UTC, Michal Jaegermann
no flags Details

Description Michal Jaegermann 2002-04-23 20:54:45 UTC
Description of Problem:

If LANG is set to en_CA, or when dictonary to use in emacs spell menu
was chosen "British" (you need a link for that to provide
/usr/lib/aspell/british and I did not try to set LANG to en_GB) then an
attempt to run spell check, in emacs - from menu or via 'ispell-buffer'
command, on a attached file ends up with:

ispell-process-line: Ispell misalignment: word `yer' point 28161; probably
incompatible versions

and an underlying process is dumped.  Try to hit 'a', for "accept", every
time when speller has doubts.  Depending on other factors some other weird
"words" may show up so the trouble may be really not in dictionaries.

If "American" dictionary is used or LANG is set to en_US then there are
no troubles.  As there are less "errors" with "American" then maybe this
dictionary kind is really not relevant and there are some overflows in 'aspell'?

The attached file is a part of a considerably bigger real paper and it is
close to the smallest one which exhibits the problem.  That means that splitting
this file in pieces and running speller on each piece separately, regardless
of which variant of English is used, is not causing any errors.

The problem is reported agains current beta but this behaviour is exactly
the same at least with emacs and aspell from 7.2 distribution.

Comment 1 Michal Jaegermann 2002-04-23 20:56:30 UTC
Created attachment 55065 [details]
A file which shows an aspell error

Comment 2 Trond Eivind Glomsrxd 2002-04-26 22:47:45 UTC
Uhh... worked here?

Can you reproduce it with a text file?

Comment 3 Michal Jaegermann 2002-04-26 23:51:55 UTC
> Uhh... worked here?

Hm, I got the same error across _three_ different machines, two underlying
versions of emacs and two distribution variants.  Careful!  It does work
when "American" dictionary is in use, i.e. if 'neighbor' is an acceptable
spelling.  The current workaround was to set explicitely a dictionary
in an emacs startup.

> Can you reproduce it with a text file?

Sorry, which "text file"?  What I attached is a text file but, as I wrote
in a report, if you will reduce it further then problem disappears.

If you would like the whole original file on which the bug hit for the first
time then I have a permission to use it so I may mail it to you.  It is
somewhere in 100K range.  Just ask for it. :-)

Comment 4 Trond Eivind Glomsrxd 2002-07-26 16:51:25 UTC
With "text file", I was thinking plain text - no LaTeX. I'm able to spellcheck
the entire file with limbo (current beta), and was with RHL 7.3 too...

(which meant it would try to fix "neighbor" :)


Note You need to log in before you can comment on or make changes to this bug.