Bug 640211 - System freeze: kernel 2.6.36-0.32.rc6.git2.fc15.x86_64
Summary: System freeze: kernel 2.6.36-0.32.rc6.git2.fc15.x86_64
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: 0xFFFF
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-05 09:04 UTC by Martin Kho
Modified: 2010-11-09 22:07 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-09 22:07:10 UTC


Attachments (Terms of Use)
Excerpt from /var/log/messages (636.60 KB, application/octet-stream)
2010-10-05 09:04 UTC, Martin Kho
no flags Details
dmesg (82.36 KB, text/plain)
2010-10-13 07:51 UTC, Martin Kho
no flags Details

Description Martin Kho 2010-10-05 09:04:03 UTC
Created attachment 451608 [details]
Excerpt from /var/log/messages

Description of problem:
When logging in into KDE (4.5.2-1) my system freezes. Text mode is okay. The crash doesn't happen with previous kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.36-0.32.rc6.git2.fc15.x86_64

How reproducible:


Steps to Reproduce:
1. Boot into rawhide (fc15)
2. Login at the graphical prompt (KDM)
3. crash
  
Actual results:
I get a text dump (see attachment) 

Expected results:
kde starts normal

Additional info:
* I've desktop effects active (XRender)
* Use two monitors (connected to VGA & DVI)
* Smolt profile: http://www.smolts.org/client/show/pub_64b0baaf-1307-4750-a5ca-dac26b4494f3
* The attachment contains messages from the crashing kernel and the previous kernel.

Comment 1 Martin Kho 2010-10-06 16:54:57 UTC
Hi,

Kernel updated to: kernel-2.6.36-0.34.rc6.git3.fc15.x86_64.

Same issue.

Martin Kho

Comment 2 Martin Kho 2010-10-08 17:36:37 UTC
Hi,

Kernel updated to: kernel-2.6.36-0.35.rc7.git0.fc15.x86_64. Issue still exists. Btw. For now I disabled desktop effects. This is a temporary work around.

Martin Kho

Comment 3 Martin Kho 2010-10-13 07:49:50 UTC
Hi,

I picked kernel 2.6.36-0.36.rc7.git3.fc15.x86_64 from koji. Desktop effects with the XRender backend (KDE) are functioning again, thanks. But there are still a bunch of nasty messages in the output of dmesg. I'll attach them, may be nice to have :-)

Martin Kho

Comment 4 Martin Kho 2010-10-13 07:51:36 UTC
Created attachment 453108 [details]
dmesg

Comment 5 Chuck Ebbert 2010-10-23 17:44:17 UTC
[   60.426367] [ INFO: HARDIRQ-safe -> HARDIRQ-unsafe lock order detected ]
[   60.426380] 2.6.36-0.36.rc7.git3.fc15.x86_64 #1
[   60.426389] ------------------------------------------------------
[   60.426401] kwin_opengl_tes/1706 [HC0[0]:SC0[0]:HE0:SE1] is trying to acquire:
[   60.426414]  (&(&mm->unused_lock)->rlock){+.+...}, at: [<ffffffffa0036394>] drm_mm_put_block+0xf6/0x12a [drm]

[   60.426454] and this task is already holding:
[   60.426466]  (&(&dev_priv->context_switch_lock)->rlock){-.....}, at: [<ffffffffa0092502>] nouveau_channel_free+0x11a/0x23e [nouveau]

[   60.426501] which would create a new lock dependency:
[   60.426511]  (&(&dev_priv->context_switch_lock)->rlock){-.....} -> (&(&mm->unused_lock)->rlock){+.+...}

Comment 6 Martin Kho 2010-11-09 11:53:41 UTC
Hi,

For me, the issue is solved after updating to:

* xorg-x11-drv-nouveau-0.0.16-11.20101026git1143e7a.fc15.x86_64.rpm
* libdrm-2.4.23-0.1.20101108.fc15.x86_64.rpm

These will be pushed with the next rawhide update, I suppose.

Thanks for the good work and please close this report.

Martin Kho

Note: There are two harmless (?) messages:
[   63.899519] [drm] nouveau 0000:01:00.0: unknown parameter 15
[   63.899937] [drm] nouveau 0000:01:00.0: unknown parameter 16

Comment 7 Ben Skeggs 2010-11-09 22:07:10 UTC
Thanks for letting me know!  Yeah those messages are harmless, the 2D driver is querying the kernel if it supports certain features that aren't yet in the rawhide kernel.  They'll make it there at some point, but things will work correctly regardless.


Note You need to log in before you can comment on or make changes to this bug.