Bug 640224 - On click of 'Topology->Agents' RHQ not showing agent UI
On click of 'Topology->Agents' RHQ not showing agent UI
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2010-10-05 05:36 EDT by Rajan Timaniya
Modified: 2010-10-29 05:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-29 05:40:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (47.49 KB, image/png)
2010-10-05 05:36 EDT, Rajan Timaniya
no flags Details
screenshot (370.37 KB, text/x-log)
2010-10-05 05:37 EDT, Rajan Timaniya
no flags Details

  None (edit)
Description Rajan Timaniya 2010-10-05 05:36:26 EDT
Created attachment 451622 [details]
screenshot

Description of problem:
On click of Topology -> Agents RHQ not showing agent UI.

Observed same behavior for 'Topology->Affinity Groups', 'Topology->Partition Events'

QE environment:
RHEL - 5.5
Postgres 8.4.2
FF - 3.0.19


Note: UI page render proper if use Ctrl + F5 

Version-Release number of selected component (if applicable):
RHQ-Master build #369
http://hudson-qe.rhq.rdu.redhat.com:8080/view/RHQ/job/ci-rhq-master/369/

How reproducible:
Intermittent

Steps to Reproduce:
1) Install RHQ server and agent
2) Log-in to RHQ
3) Go to Administrator
4) Click on 'Topology -> Agents'
  
Actual results:
On click of Topology -> Agents RHQ not showing agent UI

Expected results:
On click of 'Topology -> Agents' rhq should render agent UI.

Additional info:
Please refer attached screenshot and server log
Comment 1 Rajan Timaniya 2010-10-05 05:37:34 EDT
Created attachment 451623 [details]
screenshot
Comment 2 Sunil Kondkar 2010-10-05 06:00:05 EDT
Observed the same issue in 'Configuration' tab of resources like 'RHQ Agent', 'Apache Http Server', 'Postgres Server' and 'Postfix Server'.

Pressing Ctrl + F5 renders the resource configuration page.
Comment 3 Sunil Kondkar 2010-10-06 07:56:30 EDT
Observed the same issue in 'History' subtab of resource config. After editing and saving a config value if a user navigates to 'History' subtab to view the config update job, it is not displayed on the 'History' subtab. Clicking on the 'refresh' button or pressing ctrl+F5 displays the related config job.
Comment 4 Jay Shaughnessy 2010-10-08 16:39:18 EDT
Fix commit c9f36c62440ceb4141098b8587327f8ae1149572

The problem with the Admin pages should be fixed now. There were two problems. In certain cases the selected node was simply not generating the IFrame due to some naming mismatches resulting, I think, from when we eliminated spaces from view ids. But, more interestingly, it seems that when adding a FullHTMLPane/IFrame canvas as a child, it can actually result in a dependent (filter) canvas being added as a child as well.  This messed up some "destroy" logic we had in place, so visiting subsequent IFrames became a problem.

I did not actually see this problem in the Resource Configuration area (or any of the tabbed views, actually).  I could not reproduce that portion of the Bug.

The problem was also present in the report pages.
Comment 5 Rajan Timaniya 2010-10-29 05:40:45 EDT
Verified on RHQ-Master build #526

Observation:
1) On click of 'Topology -> Agents' rhq shows agent UI.
2) 'Configuration' and 'Configuration->History' UI of 'RHQ Agent', 'Apache Http Server', 'Postgres Server','Postfix Server', etc render without click on 'Refresh' or ctrl+F5.

Note You need to log in before you can comment on or make changes to this bug.