Bug 640232 - sendmail applies MAXHOSTNAMELEN for FQDN.
sendmail applies MAXHOSTNAMELEN for FQDN.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sendmail (Show other bugs)
5.6
All Linux
urgent Severity high
: rc
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
: ZStream
Depends On: 485380 640234
Blocks: 726094
  Show dependency treegraph
 
Reported: 2010-10-05 06:11 EDT by Jaroslav Škarvada
Modified: 2013-09-23 07:04 EDT (History)
8 users (show)

See Also:
Fixed In Version: sendmail-8.13.8-9.el5
Doc Type: Bug Fix
Doc Text:
Sendmail previously used the MAXHOSTNAMELEN macro to allocate buffers containing host names and Fully Qualified Domain Names (FQDNs). The value of the MAXHOSTNAMELEN macro is set to 64 on Red Hat Enterprise Linux systems, which means that such allocated buffer can hold at most 63 characters, but according to the RFC1035, the FQDN maximal length is defined to 255 characters. This caused problems with a FQDN resolution in case that FQDN was longer then 63 characters. With this update, the code has been modified so that the size of buffers containing FQDN is now set to 256 bytes. The issues with the FQDN resolution now no longer occurs.
Story Points: ---
Clone Of: 485380
Environment:
Last Closed: 2013-09-23 07:04:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch (1.85 KB, patch)
2010-10-06 08:54 EDT, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Comment 1 Jaroslav Škarvada 2010-10-06 08:54:07 EDT
Created attachment 451882 [details]
Proposed patch

spec file patch
Comment 2 RHEL Product and Program Management 2011-01-11 15:31:18 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2011-01-12 10:09:42 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 4 RHEL Product and Program Management 2011-05-31 09:24:07 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 Miroslav Svoboda 2011-08-01 09:19:33 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Sendmail previously used the MAXHOSTNAMELEN macro to allocate buffers containing host names and Fully Qualified Domain Names (FQDNs). The value of the MAXHOSTNAMELEN macro is set to 64 on Red Hat Enterprise Linux systems, which means that such allocated buffer can hold at most 63 characters, but according to the RFC1035, the FQDN maximal length is defined to 255 characters. This caused problems with a FQDN resolution in case that FQDN was longer then 63 characters. With this update, the code has been modified so that the size of buffers containing FQDN is now set to 256 bytes. The issues with the FQDN resolution now no longer occurs.

Note You need to log in before you can comment on or make changes to this bug.