This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 640246 - 'HTTP Response Time' -> 'Collection Interval' not setting properly
'HTTP Response Time' -> 'Collection Interval' not setting properly
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: CallTime (Show other bugs)
4.0.0
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
Corey Welton
:
Depends On:
Blocks: rhq4 gwt-scheduling
  Show dependency treegraph
 
Reported: 2010-10-05 06:39 EDT by Rajan Timaniya
Modified: 2013-08-05 20:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:09:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (164.92 KB, image/png)
2010-10-05 06:39 EDT, Rajan Timaniya
no flags Details
server log (386.08 KB, text/x-log)
2010-10-05 06:42 EDT, Rajan Timaniya
no flags Details

  None (edit)
Description Rajan Timaniya 2010-10-05 06:39:31 EDT
Created attachment 451635 [details]
screenshot

Description of problem:
'HTTP Response Time' -> 'Collection Interval' not setting properly. If user set 1-minute then its updated with 30-seconds and in case 50-minute then its update with 50-seconds.

QE environment:
RHEL - 5.5
Postgres 8.4.2
FF - 3.0.19

Version-Release number of selected component (if applicable):
RHQ-Master build #369
http://hudson-qe.rhq.rdu.redhat.com:8080/view/RHQ/job/ci-rhq-master/369/

How reproducible:
Always

Steps to Reproduce:
1) Install RHQ server and agent (configure Apache or Jboss As in agent box)
2) Log-in to RHQ
3) Navigate to Apache -> Vhost 
4) Go to 'Monitoring' -> 'Schedules' 
5) Set 'HTTP Response Time' -> 'Collection Interval' value = 1 Minute
6) Observe 'Metric Collection Schedules' for updated ' HTTP Response Time'
  
Actual results:
'HTTP Response Time' -> 'Collection Interval' not setting properly. If user set 1-minute then its updated with 30-seconds and in case 50-minute then its update with 50-seconds.

Expected results:
'HTTP Response Time' -> 'Collection Interval'  should update properly as user input.


Additional info:
Please refer attached screenshot and server log.
Comment 1 Rajan Timaniya 2010-10-05 06:42:23 EDT
Created attachment 451636 [details]
server log
Comment 2 Ian Springer 2011-02-15 12:15:28 EST
The minimum collection interval is 30 seconds, so 1 minutes being translated to 30 seconds is correct. I'll try to add a specialized message in the GUI to make this clear.

As for 50 minutes being translated to 50 seconds, that sounds like a bug.
Comment 3 Ian Springer 2011-02-15 16:39:13 EST
I modified it so that entering a value less than 30 when the selected units is "seconds" causes a validation error and disables the Set button (commit 4f5fd15 to master).

I was unable to reproduce entering a value of 50 minutes and the interval getting set to 50 seconds instead. Rajan, if you see that again, please reopen this issue and include very detailed reproduction steps.
Comment 4 Sunil Kondkar 2011-05-04 05:45:39 EDT
Verified on rhq4 release build (Version: 4.0.0 Build Number: db0c817)

Setting a value less than 30 sec displays a red circle and a hover message 'Must be atleast 30'. The Set button gets disabled.

a value of 50 minutes sets and displays 50 minutes.

Marking as verified.
Comment 5 Corey Welton 2011-05-23 21:09:21 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.