Bug 64033 - rhn_register returns a socket error
rhn_register returns a socket error
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-24 03:35 EDT by Norbert Schulz
Modified: 2007-10-23 22:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-01 07:50:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norbert Schulz 2002-04-24 03:35:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
After log in as root and type the command "rhn_register" the GUI-windoe appears
and in the shell tho following errors occure:
A socket error occured: (0, 'Error'), attempt #1
A socket error occured: (0, 'Error'), attempt #2
A socket error occured: (0, 'Error'), attempt #3
A socket error occured: (0, 'Error'), attempt #4
A socket error occured: (0, 'Error'), attempt #5

From the GUI commes an error massage "Schwerwiegender Fehler wdhrend der Ladung
der Willkommensmitteilung: Error". After pressing OK the GUI-window disappear.

The rhn_register does not work from the first beginnig. Also after updating.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.login as root
2.# rhn_register
3.
	

Additional info:
Comment 1 Adrian Likins 2002-04-24 14:48:47 EDT
socket errors generally indicate a network error of some sort
(either not being able to talk the www.rhns.redhat.com or 
a proxy if you have configured proxy support...)

can you reach www.rhns.redhat.com from that machine?

Is there a proxy configured in /etc/sysconfig/rhn/rhn_register?
Comment 2 Norbert Schulz 2002-04-25 03:26:38 EDT
I am behind a proxy. My webbrowser is conigered to go via the proxy and I can
reach the site www.rhns.redhat.com. It switchs automatically to
https://rhn.redhat.com

In the file /etc/sysconfig/rhn/rhn_register there are the following lines from
which I hope that the proxy is enabled:

enableProxy[comment]=Use a HTTP Proxy
enableProxy=1

httpProxy[comment]=HTTP proxy in host:port format, e.g. squid.redhat.com:3128
httpProxy=192.168.155.100:80

When I tried to reach https://www.rhns.redhat.com/XMLRPC which is the serverURL
a window appear to acceppt the certificate. After accepption I get the following: 

Method Not Allowed
The requested method GET is not allowed for the URL /XMLRPC.

Apache/1.3.22 Server at rhnapp-1.rwc-colo.redhat.com Port 80
Comment 3 Adrian Likins 2002-04-25 12:47:01 EDT
The proxy config looks correct. 

The error you get when trying to reach https://www.rhns.redhat.com/XMLRPC
via a browser is suspected (that url only excepts POST requests...)

With the proxy configured in rhn_register, you still get the socket
errors?
Comment 4 Norbert Schulz 2002-04-25 17:15:27 EDT
With the proxy configuration I get still the socket errors. The url  https://www.rhns.redhat.com/XMLRPC is in /etc/sysconfig/rhn/rhn_register. Is it 
possible to log in in Red Hat Network without XMLRPC? But I gues the XMLRPC is nesseccary, because it is there since the installation.

The proxy I use is Sambar5.1 on Windows 2000. The proxy is nesseccary, because there are more than one computer which need to connect to the 
internet. The proxy is configured to acceppt SSL connections.
Comment 5 Norbert Schulz 2002-05-01 07:50:45 EDT
Dear Ladies and Gentlemen,

I could solve the problem with rhn_register and up2date. As disriped before I
use an windows 2000 computer with sambar5.1 as a proxy server. With this
configuration the rhn_register is not possible.
In windows 2000 it is possible to make an internet connection available to all
users in the network without a thirt party program. On the win 2000 computer the
ip-address change automatically to 192.168.0.1. To comunicate with the win 2000
computer I changed my ip-address as well. The I configured the rhn with
rhn_regisster --configure to enable the proxy with the new ip-address. It
does'nt still work.
Then I tried something that will be a little bit confusing. I disabled the use
of the http-proxy. And now I could start rhn_register and up2date. With that
configuration I could receive updates and install them without any problem.
I do not know why to disable the http-proxy in the rhn configuration. In the
configuration of the web browser it was still neccessary to set the right proxy
ip-address.

Best regards

Norbert Schulz
Comment 6 Cristian Gafton 2002-08-15 01:23:56 EDT
My assumption is that the win2k box does some sort of NATing...

Note You need to log in before you can comment on or make changes to this bug.