Bug 64034 - quotacheck sometimes hangs on ext[23] fs.
Summary: quotacheck sometimes hangs on ext[23] fs.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: quota   
(Show other bugs)
Version: 7.2
Hardware: ia64 Linux
medium
high
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-24 07:54 UTC by Shinya Narahara
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-08 05:45:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Shinya Narahara 2002-04-24 07:54:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [ja] (WinNT; U)

Description of problem:
On ext2 or ext3 fs, the quotacheck command sometimes  hangs.
This is only on IA64, but not on IA32.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.enable user quota on your ext[23] partition.
2.If possible, make many files on its partition.
3.execute "quotacheck -ud /dev/[partition]"
	

Actual Results:  quotacheck never return.
We can do ctrl-C to stop it, but never quotachecked.


Expected Results:  quotacheck returns normally.

Additional info:

We suppose this is a bug in quota package.
On IA64, the sizeof( ino_t ) is 8byte and sizeof( ext2_ino_t ) is 4byte, so the function
ext2fs_get_next_inode() which have the i_num as its argument can't return correct value.

Our quick patch is below:

--- quota-tools/quotacheck.c.org  Mon May  6 20:53:05 2002
+++ quota-tools/quotacheck.c      Mon May  6 20:52:20 2002
@@ -360,7 +360,7 @@
 #if defined(EXT2_DIRECT)
 static int ext2 direct_scan(char *device)
 {
-       ino_t i_num;
+       ext2_ino_t i_num;
        ext2_filsys fs;
        errcode_t error;
        ext2_inode_scan scan;

or

--- quota-tools/quotacheck.c.org  Mon May  6 20:53:05 2002
+++ quota-tools/quotacheck.c      Mon May  6 20:52:20 2002
@@ -360,7 +360,7 @@
 static int ext2 direct_scan(char *device)
 {
-       ino_t i_num;
+       ino_t i_num = 0;
        ext2_filsys fs;
        errcode_t error;
        ext2_inode_scan scan;

If possible, any warning messages during compiling any packages, must be checked anytime.
This quota package has some warnings about this, so it could be avoid to include this
bug into...

Comment 1 Shinya Narahara 2002-05-08 05:45:37 UTC
Oops, the last patch is not very good one, because it has a possibility not to work
on a machine which is big endian.

The first one may be better.


Comment 2 Phil Copeland 2002-08-07 15:04:54 UTC
There is a quota-3.06-x package I've built for all archs that is based on the
SRPM in rawhide that should fix this problem (checke on ia64/7.2)

Phil
=--=


Note You need to log in before you can comment on or make changes to this bug.