Bug 640504 - spamassassin-FuzzyOcr breaking on ocr-obfuscated.eml sample
Summary: spamassassin-FuzzyOcr breaking on ocr-obfuscated.eml sample
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spamassassin-FuzzyOcr
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Andrew Colin Kissa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-06 06:53 UTC by vikram goyal
Modified: 2011-03-03 02:46 UTC (History)
3 users (show)

Fixed In Version: spamassassin-FuzzyOcr-3.6.0-6.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-21 07:24:56 UTC


Attachments (Terms of Use)
tmp debug files left after running FuzzyOcr under debug (47.08 KB, application/x-bzip)
2010-10-06 06:53 UTC, vikram goyal
no flags Details
console output running FuzzyOcr under debug (3.01 KB, application/x-bzip)
2010-10-06 06:55 UTC, vikram goyal
no flags Details
a working patch (1.86 KB, application/octet-stream)
2010-12-14 02:23 UTC, Brian
no flags Details

Description vikram goyal 2010-10-06 06:53:16 UTC
Created attachment 451818 [details]
tmp debug files left after running FuzzyOcr under debug

Description of problem:
FuzzyOcr breaking on scanning mails

Below are the log portions:

Oct  6 12:14:20  spamd[12513]: FuzzyOcr: Skipping scanset because of errors, trying next...
Oct  6 12:14:20  spamd[12513]: FuzzyOcr: Error running preprocessor(ppmtopgm): /usr/bin/ppmtopgm
Oct  6 12:14:20  spamd[12513]: FuzzyOcr: Errors in Scanset "ocrad-decolorize"
Oct  6 12:14:20  spamd[12513]: FuzzyOcr: Return code: 2048, Error: save_execute: Insecure dependency in exec while running with -T switch at /usr/share/perl5/FuzzyOcr/Misc.pm line 188.
Oct  6 12:14:20  spamd[12513]: FuzzyOcr: Skipping scanset because of errors, trying next...

Version-Release number of selected component (if applicable):
spamassassin-FuzzyOcr-3.6.0-4.fc13.noarch

How reproducible:
I checked it by running it by hand through command and testing on samples with the package.
spamassassin --debug FuzzyOcr < /usr/share/doc/spamassassin-FuzzyOcr-3.6.0/samples/

All checks run fine except for:
spamassassin --debug FuzzyOcr < /usr/share/doc/spamassassin-FuzzyOcr-3.6.0/samples/ocr-obfuscated.eml > /dev/null

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
FuzzyOcr.cf settings:
---------------------
[root@smcinsurance FuzzyOcr-debug]# grep ^[^#] /etc/mail/spamassassin/FuzzyOcr.cf 
loadplugin FuzzyOcr /usr/share/perl5/FuzzyOcr.pm
body     FUZZY_OCR                   eval:fuzzyocr_check()
body     FUZZY_OCR_WRONG_CTYPE       eval:dummy_check()
body     FUZZY_OCR_CORRUPT_IMG       eval:dummy_check()
body     FUZZY_OCR_WRONG_EXTENSION   eval:dummy_check()
body     FUZZY_OCR_KNOWN_HASH        eval:dummy_check()
describe FUZZY_OCR                   Mail contains an image with common spam text inside
describe FUZZY_OCR_WRONG_CTYPE       Mail contains an image with wrong content-type set
describe FUZZY_OCR_WRONG_EXTENSION   Mail contains an image with wrong file extension
describe FUZZY_OCR_CORRUPT_IMG       Mail contains a corrupted image
describe FUZZY_OCR_KNOWN_HASH        Mail contains an image with known hash
priority FUZZY_OCR 900
focr_verbose 3
focr_bin_helper pnmnorm, pnminvert, pamthreshold, ppmtopgm, pamtopnm
focr_bin_helper tesseract
focr_end_config
[root@smcinsurance FuzzyOcr-debug]# 
---------------------------------------------------------------------------

Thanks & Regards

Comment 1 vikram goyal 2010-10-06 06:55:40 UTC
Created attachment 451819 [details]
console output running FuzzyOcr under debug

Comment 2 Jan ONDREJ 2010-10-11 13:59:16 UTC
Same problem here. May be some similar solution can be found here:
  http://bytes.com/topic/perl/answers/673542-insecure-dependency-while-running-t-switch

I don't know, how to fix this problem but FuzzyOcr plugin is now working on my machine due to these errors. I have one image spam from internet scrore 0.0 for FUZZY_OCR and when trying to recheck, similar error messages are displayed.

Comment 3 Brian 2010-12-14 02:22:59 UTC
I found a fix:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=571218

I applied the patch (with blind trust) and FuzzyOcr is working again.

patch -d /usr/share/perl5/FuzzyOcr/ <FuzzyOcr-05.patch

attaching. . . . .

Comment 4 Brian 2010-12-14 02:23:59 UTC
Created attachment 468525 [details]
a working patch

Comment 5 Fedora Update System 2011-02-12 12:12:57 UTC
spamassassin-FuzzyOcr-3.6.0-5.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/spamassassin-FuzzyOcr-3.6.0-5.fc13

Comment 6 Fedora Update System 2011-02-12 12:13:05 UTC
spamassassin-FuzzyOcr-3.6.0-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/spamassassin-FuzzyOcr-3.6.0-5.fc14

Comment 7 Fedora Update System 2011-02-12 12:13:12 UTC
spamassassin-FuzzyOcr-3.6.0-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/spamassassin-FuzzyOcr-3.6.0-6.fc15

Comment 8 Fedora Update System 2011-02-13 03:24:29 UTC
spamassassin-FuzzyOcr-3.6.0-6.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update spamassassin-FuzzyOcr'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/spamassassin-FuzzyOcr-3.6.0-6.fc15

Comment 9 Fedora Update System 2011-02-21 07:24:51 UTC
spamassassin-FuzzyOcr-3.6.0-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-02-21 07:26:19 UTC
spamassassin-FuzzyOcr-3.6.0-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-03-03 02:46:18 UTC
spamassassin-FuzzyOcr-3.6.0-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.