Bug 640537 - Resource configuration values are removed after re-inventory
Resource configuration values are removed after re-inventory
Status: CLOSED WORKSFORME
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0
All All
low Severity medium (vote)
: ---
: ---
Assigned To: Sunil Kondkar
Corey Welton
:
Depends On:
Blocks: config/individual-config jon3-sprint1 715334
  Show dependency treegraph
 
Reported: 2010-10-06 05:41 EDT by Sunil Kondkar
Modified: 2011-06-22 10:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-17 17:04:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot_before re-inventory (150.82 KB, image/png)
2010-10-06 05:41 EDT, Sunil Kondkar
no flags Details
Screenshot_after re-inventory (146.06 KB, image/png)
2010-10-06 05:45 EDT, Sunil Kondkar
no flags Details

  None (edit)
Description Sunil Kondkar 2010-10-06 05:41:39 EDT
Created attachment 451847 [details]
Screenshot_before re-inventory

Description of problem:

Resource configuration values are removed after re-inventory. All the config fields are blanked out. Please refer the screenshot attached for a resource before and after reinventory.

Version-Release number of selected component (if applicable):
rhq build#378

How reproducible:
Always

Steps to Reproduce:

1) Login to JON using appropriate credential

2) Click on 'Inventory' menu item.

3) Click on 'Resource Inventory->Platforms'.

4) Select a resource (Ex: RHQ Agent) and click on 'Uninventory' button. (Check the config values before uninventory of the resource)

5) Reinventory the resource.

6) Navigate to the 'Configuration->Current' tab of the resource.

7) Check the config values after re-inventory.
  
Actual results:

Resource configuration values are removed after reinventory. All the config fields are blanked out.

Expected results:

Configuration values should persist after re-inventory.


Additional info:
Comment 1 Sunil Kondkar 2010-10-06 05:45:46 EDT
Created attachment 451848 [details]
Screenshot_after re-inventory
Comment 2 Sunil Kondkar 2010-10-06 07:32:28 EDT
This issue is observed intermittently.
Comment 3 Ian Springer 2011-02-15 15:06:55 EST
Sunil,

For the times when you saw the issue, did you definitely click the Save button on the Configuration>Current view to save your config changes?
Comment 4 Charles Crouch 2011-05-16 10:30:22 EDT
This would be bad if its reproducible
Comment 5 Ian Springer 2011-05-17 17:04:02 EDT
I am not able to reproduce this (using an RHQ Agent resource).

Note You need to log in before you can comment on or make changes to this bug.