Bug 64060 - Dell Latitude C810 won't suspend with apm -s
Dell Latitude C810 won't suspend with apm -s
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
skipjack-beta2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-24 15:35 EDT by Brian G. Anderson
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-25 01:52:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2002-04-24 15:35:32 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-9; Linux) 
 
Description of problem: 
When I issue a an 'apm -s' in this machine with the recent NVIDIA drivers the 
machine won't enter suspend mode.  Everything will blank, but it won't sleep.  
If I'm lucky the machine will eventually come back but the X session will be 
reset to the gdm prompt menu. 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1.issue apm -s  
2. 
3. 
  
 
Actual Results:  screen blanks but machine is still on. 
 
Expected Results:  screen should blank, I should get the little sleep beep, 
and then the machine should power down to sleep. 
 
Additional info: 
 
I have another Dell laptop (CPx) with sleep problems.  See bug 63316
Comment 1 Arjan van de Ven 2002-04-24 15:38:24 EDT
Does this work without the nvidia drivers being loaded (not even loaded and then
removed)
Comment 2 Brian G. Anderson 2002-04-25 01:52:33 EDT
When I use the generic VESA driver, suspend works fine.  It turns out the the
Dell uses a Gforce 2Go which doesn't work with the standard XFree NVIDIA
drivers.  The latest GForce driver from NVIDIA works, but doesn't suspend properly.

If this is an NVIDIA problem do I report it to them or will RedHat pass it on?

-Brian
Comment 3 Arjan van de Ven 2002-04-25 02:56:45 EDT
You'll need to go to nvidia with this; we can't support nvidia since we don't
have their source; they do have our source though.

Note You need to log in before you can comment on or make changes to this bug.