Bug 64061 - LANG environment set to invalid Locale
LANG environment set to invalid Locale
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
skipjack-beta2
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-24 15:42 EDT by Brian G. Anderson
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-01 12:15:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2002-04-24 15:42:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-9; Linux)

Description of problem:
After installing skipjack beta 2 and upgrading with up2date, all my shells have LANG=en_US.iso885915.  However, when I run programs like 'up2date' they complain that this is an invalid locale.  I have two machine at beta 2 and both exhibit this behavior.  I didn't have it in beta1.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install beta2
2. open shell
3. run up2date
 

Actual Results:  I get messages like:

(up2date:3993): Gdk-WARNING **: locale not supported by Xlib

(up2date:3993): Gdk-WARNING **: can not set locale modifiers



Expected Results:  No locale messages

Additional info:

I can get around it by unseting LANG.  However, it is a pain since it screws up most KDE menu functionality.
Comment 1 Norbert Roma 2002-04-25 14:37:41 EDT
I did not run up2date and saw the same behavior. (I added a couple of packages
on top of the default workstation configuration, but I did not remove any of the
already selected ones.)

I saw it in the first beta as well.
Comment 2 Joe Smith 2002-05-01 12:15:12 EDT
There appears to be an XFree patch that affects this:
http://www.xfree86.org/4.2.0/ERRATA.html:

 Last updated: 11 March 2002

 1. Xlib problem on Solaris and SVR4

    On some platforms, particularly Solaris and SVR4, there is a
    bug in Xlib that prevents the i18n modules from being loaded.
    The symptoms are messages like the following:

      Warning: locale not supported by Xlib, locale set to C
      Warning: X locale modifiers not supported, using default
      Failed to open input method

    A source patch is available in the fixes subdirectory
    (4.2.0-xlib-i18n-module.patch).  It is also included in the
    xf-4_2-branch branch of the XFree86 CVS repository.


Comment 3 Mike A. Harris 2002-05-20 21:22:12 EDT
This frequently reported problem, was fixed in the final release of
Red Hat Linux 7.3.  Please upgrade.

Note You need to log in before you can comment on or make changes to this bug.