Bug 640687 - Invalid configure arguments in spec
Invalid configure arguments in spec
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: SDL (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Petr Pisar
Lukas Zachar
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-06 11:44 EDT by Petr Pisar
Modified: 2012-04-03 11:20 EDT (History)
4 users (show)

See Also:
Fixed In Version: SDL-1.2.14-3.el6
Doc Type: Bug Fix
Doc Text:
Cause Building SDL package from source RPM package. Consequence `configure' script reported invalid options. Fix Unrecognized configure options have been removed from spec file. Result All options defined in spec file are recognized by SDL configure script.
Story Points: ---
Clone Of: 581056
Environment:
Last Closed: 2012-04-03 11:20:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2010-10-06 11:44:22 EDT
+++ This bug was initially created as a clone of Bug #581056 +++

SDL's spec file includes two invalid (in latest SDL) configure options:

--disable-debug
--enable-dlopen

I think they should be removed from the file.

--- Additional comment from ppisar@redhat.com on 2010-08-12 16:08:45 GMT ---

Seems valid. rpmdiff does not show any differences.

--- Additional comment from updates@fedoraproject.org on 2010-08-12 16:41:05 GMT ---

SDL-1.2.14-7.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/SDL-1.2.14-7.fc13

--- Additional comment from ppisar@redhat.com on 2010-08-12 16:49:03 GMT ---

Committed as 1.2.13-13 to F12, but built. This is just a cosmetic issue and we will not bump new release solely because of it.
Comment 1 Petr Pisar 2010-10-06 11:49:18 EDT
Output from build process:

+ ./configure --build=x86_64-unknown-linux-gnu --host=x86_64-unknown-linux-gnu --program-prefix= --disable-dependency-tracking --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/var/lib --mandir=/usr/share/man --infodir=/usr/share/info --disable-video-svga --disable-video-ggi --disable-video-aalib --disable-debug --enable-sdl-dlopen --enable-dlopen --enable-arts-shared --enable-esd-shared --enable-pulseaudio-shared --enable-alsa --disable-video-ps3 --disable-rpath
configure: WARNING: unrecognized options: --disable-dependency-tracking, --disable-debug, --enable-dlopen

Simple fix:

diff --git a/SDL.spec b/SDL.spec
index c95acee..b47f8ee 100644
--- a/SDL.spec
+++ b/SDL.spec
@@ -89,9 +89,7 @@ libtoolize
 autoconf
 %configure \
    --disable-video-svga --disable-video-ggi --disable-video-aalib \
-   --disable-debug \
    --enable-sdl-dlopen \
-   --enable-dlopen \
    --enable-arts-shared \
    --enable-esd-shared \
    --enable-pulseaudio-shared \
Comment 2 RHEL Product and Program Management 2011-01-07 10:30:59 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 RHEL Product and Program Management 2011-07-05 19:42:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 8 Petr Pisar 2012-01-10 12:03:59 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    Building SDL package from source RPM package.
Consequence
    `configure' script reported invalid options.
Fix
    Unrecognized configure options have been removed from
    spec file.
Result
    All options defined in spec file are recognized by SDL
    configure script.
Comment 9 Lukas Zachar 2012-02-21 09:53:50 EST
No configure warning in the new version.
Comment 10 errata-xmlrpc 2012-04-03 11:20:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0446.html

Note You need to log in before you can comment on or make changes to this bug.