Bug 6407 - fails to upgrade a system using a ncr53c8xx scsi controller
fails to upgrade a system using a ncr53c8xx scsi controller
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
Depends On:
  Show dependency treegraph
Reported: 1999-10-26 22:14 EDT by wulfman
Modified: 2015-01-07 18:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-02-08 14:08:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description wulfman 1999-10-26 22:14:26 EDT
I have tried to upgrade a working rh5.2 system that uses a
diamond fireport40 scsi controller ( ncr53c8xx ) chip.
the upgrade fails when installing the driver for the
ncr53c8xx controller. doing a ctl-alt-f3 the messages i get
are :

probing buses
finished probing buses
found suggestion of ncr53c8xx
found ncr53c8xx
found devices justprobe is 0
going to insmod ncr53c8xx.o (path is NULL)

it seems that the installer has been rendered useless to
those who have the ncr53c8xx chips for scsi controllers
i have tried 3 motherboards and also fresh installs on other
systems with diffrent scsi drives ( including segate
baracuda drives ) i also have tried the rh6.1 boot.img
with the same result

anybody have any suggestions ? as for now i guess i have to
remain on rh5.2
Comment 1 wulfman 1999-10-27 16:59:59 EDT
seems that redhat6.0 uses a heavly moidified version of the
ncr53c8xx.c driver. they have added more excption handling code
including one for SIR_RESEL_BAD_I_T_L_Q  error # 16 that seems to be
the problem. after looking at the error output of the installer i get

<6>ncr53c875j-0-<0,0>:  phase change 6-7 7@o3bb44c8 resid=4.
<4>ncr53c875j-0:0: SIR 16, incorrect nexus identification on

i cant make any further error identification cause i dont have the
driver block diagrams or the flow chart   i can help by email if
required :)

------- Additional Comments From   10/28/99 02:53 -------
I just got my 6.1 upgrade .. guess what it fails the same way
same problem same description
as well as a ppp bug that says that there is no secret password to
auth the ppp0 connection ... why does every upgrade break somthing
else in the process ?

------- Additional Comments From   10/31/99 11:21 -------
seems that this is a kernal bug. in the latest kernal release there
are 3 versions of the scsi driver one for ncr53c8xx, ncr53c7xx and one
for the sym53c8xx the diamond fireport uses the symbios part thant the
point in the code where the error occurs has some error exception
handling code that is not in the 3.1h version of the ncr53c8xx code
that is shipped with RH6.0 and 6.1..... is there a workaround for this
problem ?...does the supp floppy image on RH6.1 have the new scsi
driver in it ? just wondering why nobody has answered this bug report
Comment 2 Duane Voth 1999-11-13 10:55:59 EST
Looks like I've hit this same problem.

The ncr53c8xx.o version 3.2a-2 driver gets stuck in a loop
when certain peripherals are attached on the scsi bus.  (During
an install, this will effectively hang the installation.)

The 2.4 version of the driver (RedHat 5.0) works fine with
these same devices.  Disconnecting the peripherals prior to
an install allows the driver to complete init and the install
can continue (on different drives).  The driver reports the

..................SCSI Phase error
...(things I can't capture)...
ncr53c8xx_reset: pid=11 reset_flags=2 serial_number=18
ncr53c010-0: restart (scsi reset).
ncr53c010-0-<0,0>: phase change 6-7 8@0039acc8 resid=5.
ncr53c010-0-<0,*>: asynchronous.
ncr53c010-0-0: SIR 16, incorrect nexus identification on reselection
(here is pauses for a minute or two, then:)
SCSI host 0 abort (pid 11) time out - resetting
SCSI bus is being reset for host 0 channel 0.

then the whole thing repeats with only the serial numbers
incremented.  Over night these serial numbers have gone to 770.

The devices are a disk drive at id 0 and a CDROM drive at 6
I'll try to get the ident strings on them.
Comment 3 Duane Voth 1999-11-13 17:55:59 EST
Ok, it is only the hard disk that is causing problems, the CDROM
is recognized with no problems and the driver operates with no
problems.  Device idents are:

scsi : 1 host.
  Vendor: TANDEM    Model: 4255-1            Rev: 5t5t
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
  Vendor: TOSHIBA   Model: CD-ROM XM-3401TA  Rev: 0283
  Type:   CD-ROM                             ANSI SCSI revision: 02

Also, the disk is doing an M_REJECT; the errors prior to
those listed in my last note are:

<6>ncr53c810-0-<0,0>: M_REJECT received (80:8)..
<6>ncr53c810-0-<0,0>: M_REJECT received (80:8)..
<6>ncr53c810-0-<0,0>: M_REJECT received (80:8)..
<6>ncr53c810-0-<0,0>: M_REJECT received (80:8)..
ncr53c810-0: SCSI phase error fixup: CCB already dequeued (0xc048a820)
ncr53c810-0:0: SIR 16, incorrect nexus identification on reselection
scsi : aborting command due to timeout : pid 24, scsi0, channel 0, id 0, lun 0 R
ead Capacity 00 00 00 00 00 00 00 00 00
ncr53c8xx_abort: pid=24 serial_number=31 serial_number_at_timeout=31

I'm running from an IDE and can load the ncr53c8xx.o module only
when necessary, so I'm ready to test fixes - if someone wants to
give it a try.  But I don't know for how long I'll have this machine...
Comment 4 Jay Turner 2000-02-08 14:08:59 EST
Try the latest RawHide.  Reopen this bug if you are still having problems.

Note You need to log in before you can comment on or make changes to this bug.