Bug 64079 - apm doesn't report battery charge level on Dell C810
apm doesn't report battery charge level on Dell C810
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: apmd (Show other bugs)
skipjack-beta2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-25 02:08 EDT by Brian G. Anderson
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-01 23:56:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2002-04-25 02:08:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
I have a Dell lattitude c810 with Bios leve A05.  The command 'apm -v' doesn't
report a battery level either when the machine is on battery or when its
charging.  The command 'apm -s' yeilds:

APM BIOS 1.2 (kernel driver 1.16)
AC off-line

I can use the Fn+F3 (BIOS Battery Viewer) to see the level.

Also when the battery does get low, the machine does show low battery level
messages, but the level says some thing -1 minutes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start the computer
2.type apm -v
3.
	

Actual Results:  only reports the machine is offline, but not battery level

Additional info:

The battery level doesn't show on Redhat 7.2 either.
Comment 1 Brian G. Anderson 2002-05-01 23:55:56 EDT
Upgrading to BIOS level A07 clears this problem.  I now get proper battery reports.
Comment 2 Bernhard Rosenkraenzer 2002-05-06 11:04:43 EDT
Since it was a BIOS (and not Linux) problem, I'm closing this as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.