Bug 640825 - RFE: Allow specifying the raw path to a disk for more exotic setups
Summary: RFE: Allow specifying the raw path to a disk for more exotic setups
Keywords:
Status: CLOSED DUPLICATE of bug 557107
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-06 20:54 UTC by Nuutti Kotivuori
Modified: 2012-02-07 22:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-07 22:26:56 UTC


Attachments (Terms of Use)

Description Nuutti Kotivuori 2010-10-06 20:54:19 UTC
Description of problem:
libvirt has explicit support for a few storage backends and they are managed as storage pools. However, the world is full of all sorts of disk access methods - loopback files, ata-over-ethernet drives, NBD drives, mmc devices, etc. Please allow specifying manually the explicit path to the disk to be used, so all of these can be supported by virt-manager without resorting to editing xml configurations.

Comment 1 Cole Robinson 2012-02-07 22:26:56 UTC
This already works in the local case, provided the user has permissions to actually see the storage.

Proper fix is actually more managed storage usage :) Use directory pools to verify storage actually exists on the remote machine and possibly try and get format info about it, but do all this automatically. That way a user can enter an arbitrary path, and we use libvirt's storage enumeration to make sure it exists and has correct permissions, etc.

*** This bug has been marked as a duplicate of bug 557107 ***


Note You need to log in before you can comment on or make changes to this bug.