Bug 64084 - kwinrc, ALT+TAB locks KDE and keyboard, crash
kwinrc, ALT+TAB locks KDE and keyboard, crash
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-25 09:06 EDT by Michael Schwendt
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-19 10:02:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
KDE config files for reproducing this bug (742 bytes, application/x-gzip)
2002-04-25 09:07 EDT, Michael Schwendt
no flags Details

  None (edit)
Description Michael Schwendt 2002-04-25 09:06:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
This is about an update installation of Skipjack beta2 over Enigma.

An old but updated KDE config file in $HOME/.kde/share/config causes the task
switcher (ALT+TAB) to lock the keyboard and KDE. Mouse cannot click anything
anymore. Keyboard is dead. CTRL+ALT+BACKSPACE doesn't work either. Didn't try to
log into the machine via network to see what would still be running. (Kernel is
still seen flushing the disk buffers periodically.) I've went through
$HOME/.kde/share/config in binary search fashion to remove every file that
doesn't affect this bug and find what the cause of this is.

Version-Release number of selected component (if applicable):
3.0.0-9

How reproducible:
Always

Steps to Reproduce: [see attached file]
1. rm -rf ~/.kde
2. tar xfz home.kde.tgz -C ~
3. log into KDE via kdm
4. have no windows/tasks active (!)
5. press ALT+TAB

Actual Results:  _No_ "*** No Tasks ***" box is displayed. Further key presses
or mouse clicks lock the system.

Expected Results:  A dialog box reading "*** No Tasks ***" should appear. KDE
should not lock.


Additional info: [If any window is open, the task switcher toggles through the
available windows, but without its selection box.]

It's ~/.kde/share/config/kwinrc that's is the problem. Removing it is a
work-around. But anyone with a similar kwinrc doing an update installation over
Enigma is likely to see this killer bug.
Comment 1 Michael Schwendt 2002-04-25 09:07:23 EDT
Created attachment 55284 [details]
KDE config files for reproducing this bug
Comment 2 Michael Schwendt 2003-08-19 10:02:46 EDT
It didn't make any sense to change the "Product:" and "Version:" fields to Red
Hat Linux 9, since the original report was not about that product.

I smell that no one is going to take a shot at debugging or fixing this rare bug
anymore these days. ;)

Hence I close this as WONTFIX. If you disagree, reopen.

Note You need to log in before you can comment on or make changes to this bug.