Bug 640928 - system.convertToFlexEntitlement, redstone.xmlrpc.XmlRpcFault: unhandled internal exception: java.lang.Integer incompatible with java.lang.Long
system.convertToFlexEntitlement, redstone.xmlrpc.XmlRpcFault: unhandled inter...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
540
All Linux
high Severity high
: ---
: ---
Assigned To: Tomas Lestach
Šimon Lukašík
:
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2010-10-07 05:08 EDT by Jiri Kastner
Modified: 2011-03-17 10:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause Incompatible method parameters Consequence system.convertToFlexEntitlement fails with redstone.xmlrpc.XmlRpcFault: unhandled internal exception: java.lang.Integer incompatible with java.lang.Long Result system.convertToFlexEntitlement won't fail at right at the beginning, but works as expected
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 10:11:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Kastner 2010-10-07 05:08:26 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. register to satellite 5.4 rhel5u5 kvm guest running on rhel6 kvm host (it will consume regular entitlement)
2. use api call bellow
3. check output
  
Actual results:
import sys, xmlrpclib
USER='censored'
PASS='censored'
SERVER='https://censored/rpc/api'

client = xmlrpclib.Server(SERVER, verbose=0)
key = client.auth.login(USER, PASS)
x = client.system.convertToFlexEntitlement(key,[1000010010],'rhel-server')
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1253, in request
    return self._parse_response(h.getfile(), sock)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1392, in _parse_response
    return u.close()
  File "/usr/lib64/python2.6/xmlrpclib.py", line 838, in close
    raise Fault(**self._stack[0])
xmlrpclib.Fault: <Fault -1: 'redstone.xmlrpc.XmlRpcFault: unhandled internal exception: java.lang.Integer incompatible with java.lang.Long'>
x = client.system.convertToFlexEntitlement(key,[long(1000010010)],'rhel-server')
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1253, in request
    return self._parse_response(h.getfile(), sock)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1392, in _parse_response
    return u.close()
  File "/usr/lib64/python2.6/xmlrpclib.py", line 838, in close
    raise Fault(**self._stack[0])
xmlrpclib.Fault: <Fault -1: 'redstone.xmlrpc.XmlRpcFault: unhandled internal exception: java.lang.Integer incompatible with java.lang.Long'>



Expected results:
returns number of converted systems as stated in api overview

Additional info:
Comment 3 Tomas Lestach 2010-12-22 10:03:16 EST
Taking ... and fixing.

spacewalk.git: fd2fbec691f6b80a15d049eff2f15ca26039ed67

(not moving to MODIFIED, because I need to run some tests)
Comment 4 Tomas Lestach 2011-01-03 12:24:03 EST
Quick test passed, moving to MODIFIED
Comment 8 Tomas Lestach 2011-02-14 09:19:45 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Incompatible method parameters

Consequence
system.convertToFlexEntitlement fails with redstone.xmlrpc.XmlRpcFault: unhandled internal exception: java.lang.Integer incompatible with java.lang.Long

Result
system.convertToFlexEntitlement won't fail at right at the beginning, but works as expected
Comment 9 Šimon Lukašík 2011-02-18 07:44:24 EST
Taking QA contact. Good candidate for automation.
Comment 10 Šimon Lukašík 2011-02-21 03:05:42 EST
Changing to VERIFIED.

Testing procedure:
Automated test

Verified against:
spacewalk-java-1.2.39-36.el5sat
Comment 11 errata-xmlrpc 2011-03-17 10:11:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0362.html

Note You need to log in before you can comment on or make changes to this bug.