Bug 640943 - Fedora 13 could not detect existing OS (Linux)
Fedora 13 could not detect existing OS (Linux)
Status: CLOSED DUPLICATE of bug 580176
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-07 05:59 EDT by Michael Adeyeye
Modified: 2011-03-02 19:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-02 19:20:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Adeyeye 2010-10-07 05:59:11 EDT
Description of problem:
I wanted to dual-boot; so, i tried to install Fedora 13 on my PC. I chose the shrink option during the installation, having had Ubuntu 10.10 use the entire disk. Anaconda shrank the drive but could not detect the existing Ubuntu OS. 

Version-Release number of selected component (if applicable):
Fedora 13

How reproducible:
Try an install Fedora 13 on a PC already running Ubuntu and has no free partition. Choose the shrink option during the installation

Steps to Reproduce:
1. Get a PC running Ubuntu and has no free partition/space
2. Choose the shrink option when installing Fedora
3. Restart the machine after installation
  
Actual results:
You would not be able to load Ubuntu again. The bootloader do not give option to choose either Fedora or Ubuntu. The PC would only load Fedora 13.


Expected results:
The bootloader (grub/2) should list the two OSs to choose one from.

Additional info:
Comment 1 Jan Wildeboer 2010-10-07 06:26:54 EDT
Some more details:

Partitions:

/dev/sda1 - Ubuntu install (partition set to bootable)
/dev/sda2 - Fedora /boot (500MB)
/dev/sda3 - Fedora PV containing LVs for /home and /

grub was somehow created without a grub.conf file, which I recreated with grub and some magic.

It correctly discovered the fedora install but did not inform of the bpoot flag on sda1 and seemingly completely ignored it.
Comment 2 Brian Lane 2010-10-07 12:56:22 EDT
Could you attach:
  * install logs from /var/log/anaconda*
  * /etc/grub.conf

What version of Ubuntu?
Comment 3 Brian Lane 2011-03-02 19:20:36 EST

*** This bug has been marked as a duplicate of bug 580176 ***

Note You need to log in before you can comment on or make changes to this bug.