Bug 640952 - Link 'Changed by <user>' on 'Summary->Dashboard' tab of resource redirects to old UI
Link 'Changed by <user>' on 'Summary->Dashboard' tab of resource redirects to...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: config/individual-config
  Show dependency treegraph
 
Reported: 2010-10-07 06:36 EDT by Sunil Kondkar
Modified: 2011-05-23 21:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot (184.70 KB, image/png)
2010-10-07 06:37 EDT, Sunil Kondkar
no flags Details

  None (edit)
Description Sunil Kondkar 2010-10-07 06:36:36 EDT
Description of problem:

If user edits a config value of a resource, a link 'Changed by <user>' is provided to view the config update on 'Summary->Dashboard' tab. Clicking on this link redirects user to 'Configuration->History' tab displaying menu and left-nav of old UI.

Please refer the screenshot attached.

Version-Release number of selected component (if applicable):
rhq build#379

How reproducible:
Always

Steps to Reproduce:

1) Login to JON using appropriate credential

2) Click on 'Inventory' menu item.

3) Click on 'Resource Inventory->Platoforms'.

4) Click on a resource (Ex: RHQ Agent) in the resource tree.

5) Navigate to the 'Configuration->Current' tab.

6) Edit a config value and save.

7) Navigate to the 'Summary->Dashboard' page of the resource and verify if it displays link like 'Changed by <user>'.

8) Click on the link 'Changed by <user>'.
  
Actual results:

It redirects to 'Configuration->History' subtab displaying old UI (including menu and left navigation)

Expected results:

It should redirect to 'Configuration->History' subtab and should display either new gwt UI or only specific old UI (without menu and left-nav).

Additional info:
Comment 1 Sunil Kondkar 2010-10-07 06:37:49 EDT
Created attachment 452082 [details]
Screenshot
Comment 2 Jay Shaughnessy 2011-02-14 09:35:32 EST
Seems to be working as expected now.
Comment 3 Sunil Kondkar 2011-04-07 08:28:50 EDT
Verified on build#1129 (Version: 4.0.0-SNAPSHOT Build Number: 5a40add)

Now there is no link 'Changed By <user> on Summary->Activity page in the new UI. There is text for username who did the config update in 'User' column. Clicking on the version number redirect to 'Configuration->History' sub tab as expected.

Marking as verified.
Comment 4 Corey Welton 2011-05-23 21:12:39 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:12:40 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.