Bug 640972 - [abrt] sugar-0.90.2-1.fc14: Process /usr/bin/python was killed by signal 6 (SIGABRT)
Summary: [abrt] sugar-0.90.2-1.fc14: Process /usr/bin/python was killed by signal 6 (S...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:fdb01b414ad94f4ae0cc6324714...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-07 12:16 UTC by Bernie Innocenti
Modified: 2011-07-08 18:03 UTC (History)
11 users (show)

Fixed In Version: pygobject2-2.21.5-4.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-10 13:30:02 UTC


Attachments (Terms of Use)
File: backtrace (98.91 KB, text/plain)
2010-10-07 12:16 UTC, Bernie Innocenti
no flags Details

Description Bernie Innocenti 2010-10-07 12:16:10 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: python /usr/bin/sugar-session
component: sugar
executable: /usr/bin/python
kernel: 2.6.35.4-28.fc14.x86_64
package: sugar-0.90.2-1.fc14
rating: 4
reason: Process /usr/bin/python was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1286452799
uid: 1000

comment
-----
This is certainly http://bugs.sugarlabs.org/ticket/2064 , finally reproduced outside Dextrose.


How to reproduce
-----
1. click on an icon (in this case, it was the Log activity)
2. wait one second
3. watch the fireworks

Comment 1 Bernie Innocenti 2010-10-07 12:16:18 UTC
Created attachment 452094 [details]
File: backtrace

Comment 2 Tomeu Vizoso 2010-10-07 12:46:28 UTC
(In reply to comment #0)
> 1. click on an icon (in this case, it was the Log activity)

You mean it happens with other activities as well? (Make sure you haven't started Log when you try)

Comment 3 Bernie Innocenti 2010-10-07 12:53:20 UTC
(In reply to comment #2)
> You mean it happens with other activities as well? (Make sure you haven't
> started Log when you try)

Yes, this is for sure sl#2064: it happens by clicking on random icons in the journal or in the activity list... even on the frame. We've been chasing it for 6 months.

Comment 4 Tomeu Vizoso 2010-10-07 13:01:18 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > You mean it happens with other activities as well? (Make sure you haven't
> > started Log when you try)
> 
> Yes, this is for sure sl#2064: it happens by clicking on random icons in the
> journal or in the activity list... even on the frame. We've been chasing it for
> 6 months.

So the reason why I'm asking this is because earlier it was suggested that it happened only after a DBus exception, and Log in F14 is known to raise one because it expects the old PS being there.

So if anybody has a hint of what can be leaving the refcount wrong, it would help a lot tracking this bug.

Comment 5 Bernie Innocenti 2010-10-07 13:05:32 UTC
The inconsistency in the reference counts during garbage collection could be caused by memory corruption or a bug in one of the Python bindings: dbus-python, pygtk2, pygobject2, gnome-python2-rsvg...

It may also be a threading bug in the gtk bindings, because the dbus bindings spawn an extra thread which re-enters the gtk mainloop.

Reassigning to Python for the time being. Malcolm, please help: this bug is extremely hard to reproduce and extremely annoying for our users.

Comment 6 Bernie Innocenti 2010-10-07 13:13:48 UTC
(In reply to comment #4)
> So the reason why I'm asking this is because earlier it was suggested that it
> happened only after a DBus exception, and Log in F14 is known to raise one
> because it expects the old PS being there.

In this particular case, Sugar died taking the X session with it, before Log could initialize.

In the log of the Sugar process, there's one dbus exception fired at initialization time:

 1286452807.152217 ERROR dbus.proxies: Introspect error on org.freedesktop.ohm:/org/freedesktop/ohm/Keystore: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ohm was not provided by any .service files
 1286452807.153741 ERROR root: Cannot unfreeze the DCON
:30

At least 10 seconds elapsed between this and the actual death, but it's possible that Python's GC had not ever fired before. Here's a working theory: clicking on icons causes the activity launcher to start, which often allocates enough memory to trigger a collection round. This would explain why we usually get the crash just after clicking on icons.

Comment 7 Bernie Innocenti 2010-10-07 13:34:06 UTC
gc->gc.gc_refs really is 0:

 (gdb) p generations[0].head
 $8 = {gc = {gc_next = 0x1e336f0, gc_prev = 0x1c66770, gc_refs = 0}, dummy = <invalid float value>}

Full coredump available here: http://people.sugarlabs.org/bernie/sugar/sl2064-coredump

Resume it with:

  gdb /usr/bin/python sl2064-coredump

Comment 8 Bernie Innocenti 2010-10-07 13:35:07 UTC
You need python-2.7-8.fc14.1.x86_64 to use the above coredump. I could provide the binary if needed.

Comment 9 Fedora Update System 2011-06-06 16:17:26 UTC
pygobject2-2.21.5-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pygobject2-2.21.5-4.fc14

Comment 10 Fedora Update System 2011-06-06 16:18:33 UTC
pygobject2-2.28.4-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/pygobject2-2.28.4-3.fc15

Comment 11 Fedora Update System 2011-06-07 04:36:59 UTC
Package pygobject2-2.21.5-4.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pygobject2-2.21.5-4.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/pygobject2-2.21.5-4.fc14
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2011-06-10 13:29:54 UTC
pygobject2-2.28.4-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-07-08 18:03:30 UTC
pygobject2-2.21.5-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.