Bug 641034 - findLiveData doesn't return any Live Data
findLiveData doesn't return any Live Data
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Web Services (Show other bugs)
3.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-07 11:36 EDT by Isaac
Modified: 2014-05-09 12:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-09 12:04:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Isaac 2010-10-07 11:36:53 EDT
Description of problem:
findLiveData only returns the Measurement Names and Ids and does not return any live data values.

Version-Release number of selected component (if applicable):


How reproducible:
Consistent.

Steps to Reproduce:
1. Call login action to get sessionId
2. Call findLiveData action

Example request:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:web="http://www.rhq-project.org/2.3/2009/9/Webservices.xsd">
   <soapenv:Header/>
   <soapenv:Body>
      <web:findLiveData>
         <!--Optional:-->
         <subject>
            <factive>true</factive>
            <fsystem>false</fsystem>
            <id>10001</id>
            <name>isaac</name>
            <sessionId>1825703509</sessionId>
         </subject>
         <resourceId>10001</resourceId>  <!-- Platform -->
         <!--Zero or more repetitions:-->
         <definitionIds>10025</definitionIds>  
         <definitionIds>10026</definitionIds>  
         <definitionIds>10027</definitionIds>
         <definitionIds>10029</definitionIds>
      </web:findLiveData>
   </soapenv:Body>
</soapenv:Envelope>
Actual results:

Example Response:

<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">
   <env:Header/>
   <env:Body>
      <ns2:findLiveDataResponse xmlns:ns2="http://www.rhq-project.org/2.3/2009/9/Webservices.xsd">
         <return>
            <id/>
            <name>Native.SwapInfo.used</name>
         </return>
         <return>
            <id/>
            <name>CpuPerc.idle</name>
         </return>
         <return>
            <id/>
            <name>Native.SwapInfo.total</name>
         </return>
         <return>
            <id/>
            <name>CpuPerc.user</name>
         </return>
      </ns2:findLiveDataResponse>
   </env:Body>
</env:Envelope>

Expected results:

Need the Measurement values for each definitionId

Additional info:

Problem seems to be that the org.rhq.core.domain.measurement.MeasurementData is an Abstract and there's no mapping of the implementations so that the WSDL can generate the response types.
Comment 1 Isaac 2010-10-07 19:43:02 EDT
Adding the following annotation to the org.rhq.core.domain.measurement.MeasurementData java class resolves the issue: 


@XmlSeeAlso( { MeasurementDataNumeric.class, 
	       MeasurementDataNumeric1D.class, 
  	       MeasurementDataNumeric1H.class, 
  	       MeasurementDataNumeric6H.class,
	       MeasurementDataTrait.class
             })
Comment 2 Jay Shaughnessy 2014-05-09 12:04:12 EDT
WebServices are no longer supported.

Note You need to log in before you can comment on or make changes to this bug.