Bug 641083 - package conflict with rubygem-term-ansicolor
Summary: package conflict with rubygem-term-ansicolor
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-term-ansicolor
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Klepek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-07 18:08 UTC by stan
Modified: 2011-08-16 21:03 UTC (History)
5 users (show)

Fixed In Version: rubygem-term-ansicolor-1.0.6-2.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-03 02:29:27 UTC


Attachments (Terms of Use)

Description stan 2010-10-07 18:08:34 UTC
Description of problem:
Transaction Check Error:
  file /usr/bin/cdiff from install of colordiff-1.0.9-3.fc12.noarch conflicts with file from package rubygem-term-ansicolor-1.0.5-1.fc13.noarch

Version-Release number of selected component (if applicable):
see above

How reproducible:
every time

Steps to Reproduce:
1.install rubygem-term-ansicolor
2. install colordiff
3.
  
Actual results:
above error

Expected results:
install without problem

Additional info:

Comment 1 Ville Skyttä 2010-10-07 20:30:25 UTC
This should be addressed in rubygem-term-ansicolor, preferably upstream.

/usr/bin/cdiff has been in the Fedora colordiff package since 2004, in upstream colordiff since 2005, and FWIW in FreeBSD (which should be of interest at least to rubygem-term-ansicolor upstream) at least since 2000.

Comment 2 Jan Klepek 2010-10-07 21:37:39 UTC
upstream was contacted about this issue

Comment 3 Jan Klepek 2011-07-23 19:23:10 UTC
upstream did not responded, binary removed.

Comment 4 Fedora Update System 2011-07-23 19:26:34 UTC
rubygem-term-ansicolor-1.0.6-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/rubygem-term-ansicolor-1.0.6-2.el5

Comment 5 Fedora Update System 2011-07-23 19:26:47 UTC
rubygem-term-ansicolor-1.0.6-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rubygem-term-ansicolor-1.0.6-2.fc15

Comment 6 Fedora Update System 2011-07-26 03:32:58 UTC
Package rubygem-term-ansicolor-1.0.6-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-term-ansicolor-1.0.6-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/rubygem-term-ansicolor-1.0.6-2.fc15
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-08-03 02:29:17 UTC
rubygem-term-ansicolor-1.0.6-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-08-16 21:03:14 UTC
rubygem-term-ansicolor-1.0.6-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.