Bug 641163 - wireshark association with *.pcap files required
Summary: wireshark association with *.pcap files required
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wireshark
Version: 13
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Radek Vokál
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-07 21:35 UTC by Max Romanov
Modified: 2010-11-21 21:54 UTC (History)
3 users (show)

Fixed In Version: wireshark-1.4.1-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-21 21:54:16 UTC
Type: ---


Attachments (Terms of Use)
Suggested changes (33.02 KB, application/x-gzip)
2010-10-07 21:35 UTC, Max Romanov
no flags Details

Description Max Romanov 2010-10-07 21:35:21 UTC
Created attachment 452206 [details]
Suggested changes

Description of problem:
Would be nice to open *.pcap files directly from nautilus or web browser.

Version-Release number of selected component (if applicable):
wireshark-1.2.11-1.fc13

Steps to Reproduce:
1. double-click on local *.pcap file in nautilus
2. in firefox address bar type URL for remote *.pcap file
  
Actual results:
1. 'no associated application' message
2. prompt to save the file/choose an application

Expected results:
1. wireshark launched and opens selected file
2. option 'Open with wireshark' present in download prompt.

Additional info:
archive with suggested src.rpm changes attached.
Extract attachment to src RPM hierarchy root.
File list:
wireshark-1.2.11.patch
SOURCES/wiresharkdoc-16x16.png
SOURCES/wiresharkdoc-24x24.png
SOURCES/wiresharkdoc-256x256.png
SOURCES/wiresharkdoc-32x32.png
SOURCES/wiresharkdoc-48x48.png

application/x-pcap registered (aliased with application/pcap, because some web servers respond with such content-type for pcap files).

wiresharkdoc-* icons were extracted from wiresharkdoc.ico

Comment 1 Fedora Update System 2010-10-22 10:40:35 UTC
wireshark-1.4.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/wireshark-1.4.1-1.fc14

Comment 2 Jan Safranek 2010-10-22 10:41:43 UTC
Fixing in Fedora 14 for now, I'll update F13 when it is well tested.

Comment 3 Fedora Update System 2010-10-28 05:51:13 UTC
wireshark-1.4.1-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wireshark'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/wireshark-1.4.1-1.fc14

Comment 4 Fedora Update System 2010-11-04 15:43:57 UTC
wireshark-1.4.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/wireshark-1.4.1-2.fc14

Comment 5 Fedora Update System 2010-11-21 21:54:02 UTC
wireshark-1.4.1-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.